summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2019-07-17 23:20:52 +1200
committerKent Fredric <kentnl@gentoo.org>2019-07-17 23:21:24 +1200
commit7f7c9e9e80b830a7a5f30ffc9fa5ef3215e92c5a (patch)
treeab07bb92521747a85f20eb491ce4a0a455aeb3a0
parentdev-perl/Alien-Libxml2: Add w/ version 0.90.0 (diff)
downloadgentoo-7f7c9e9e80b830a7a5f30ffc9fa5ef3215e92c5a.tar.gz
gentoo-7f7c9e9e80b830a7a5f30ffc9fa5ef3215e92c5a.tar.bz2
gentoo-7f7c9e9e80b830a7a5f30ffc9fa5ef3215e92c5a.zip
dev-perl/XML-LibXML: Bump to version 2.20.100 re bug #595098
- Bumping because upstream have done some splitting, and now deem the problems in bug #595098 to be potentially a problem in one of these new dependencies. Whether or not its actually fixed is to be seen, but if it isn't, it has to be updated before they'll look at it. Upstream: - Mark as working with libxml2 2.9.9 and lower - Allow LibParser to be provided for all methods - Portability fixes - Convert to Alien::Libxml2 Keywords: - Due to new dependencies, all the following keywords are dropped: alpha, {amd64,x86}-{fbsd,linux}, arm{,64}, hppa ia64, m68k-mint, mips ppc{,-aix,-macos,64}, riscv s390, sparc{,-solaris,64-solaris} {x64,x86}-{macos,solaris} Bug: https://bugs.gentoo.org/595098 Bug: https://rt.cpan.org/Ticket/Display.html?id=119715 Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
-rw-r--r--dev-perl/XML-LibXML/Manifest1
-rw-r--r--dev-perl/XML-LibXML/XML-LibXML-2.20.100.ebuild78
2 files changed, 79 insertions, 0 deletions
diff --git a/dev-perl/XML-LibXML/Manifest b/dev-perl/XML-LibXML/Manifest
index cb0174235552..a5485002085a 100644
--- a/dev-perl/XML-LibXML/Manifest
+++ b/dev-perl/XML-LibXML/Manifest
@@ -1,3 +1,4 @@
DIST XML-LibXML-2.0128.tar.gz 466334 BLAKE2B 7b7de24ed9cbafde79061e70247ed715e6009acf9d0ef75cc08d838d51c7b736ee7f4e57f069b1112c171ac398c28745082760f8e1d892834ab0c811c8a09e57 SHA512 c388570d0a140f3b92ab9922d9c917fba791e804b160822eeff91923891059ba189ad3743f2ffd13f7f4c92a3e8db1ee5fae588007d3fcf50251d9803e8e261b
DIST XML-LibXML-2.0129.tar.gz 468838 BLAKE2B dce86bff8d4fcc87d5fc1e957ec7f89586ba8b34fd826680267995912ac54b1460850a22ea572a55d441fdb5719f8fbe6070b0d64f39f3e4fac9a5252ffd4396 SHA512 f17c61052975ecc188c285ee93dbb07926c880a28e49afdd5af0c7c997e8b12be72412d0964391f1232f853935ee0ff2838cd5d62f8f3b4f52c341904069ccea
DIST XML-LibXML-2.0132.tar.gz 469983 BLAKE2B 66002c35adc1156af76f16af2a1b4617ef25470cb434ee73dd9242fdc37a20d5d417ce5003ca202f69de08e053705129c083e65d483ae7e85375ae2ad6cbedc5 SHA512 3df1cb67ea955133492f2b6f8def2b28079c59e99170a31820aca69ea81686c4b67171509f1b311faab9389d200c4a24942b3950d7c0730ff1233a009b398fce
+DIST XML-LibXML-2.0201.tar.gz 462237 BLAKE2B 17313daca3e87b12f0d3161f628dbd5ee3fbd233747a9602b275e13f14e9710eba424804b1f57b40c2f0f340d1c29ca0518ffc395b808b0e9851c61943d73b22 SHA512 988bc98e7f3e426202b9770ef055df68abc861b935dcdd8ecbefaaa7cd528abc35cce9bd75f2f10412917178f6b74ac6bf953feac130b1f9afe9e18c16139e47
diff --git a/dev-perl/XML-LibXML/XML-LibXML-2.20.100.ebuild b/dev-perl/XML-LibXML/XML-LibXML-2.20.100.ebuild
new file mode 100644
index 000000000000..3df310ace466
--- /dev/null
+++ b/dev-perl/XML-LibXML/XML-LibXML-2.20.100.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=SHLOMIF
+DIST_VERSION=2.0201
+DIST_EXAMPLES=("example/*")
+inherit perl-module
+
+DESCRIPTION="Perl binding for libxml2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test minimal"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Encode
+ >=virtual/perl-Exporter-5.570.0
+ virtual/perl-IO
+ virtual/perl-Scalar-List-Utils
+ >=dev-perl/XML-SAX-0.120.0
+ >=dev-libs/libxml2-2.6.21:2=
+ dev-perl/XML-SAX-Base
+ >=dev-perl/XML-NamespaceSupport-1.70.0
+ virtual/perl-XSLoader
+ virtual/perl-parent
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ dev-perl/Alien-Libxml2
+ test? (
+ !minimal? (
+ dev-perl/Test-LeakTrace
+ )
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.12.800-disable-expanding.patch"
+)
+
+PERL_RM_FILES=(
+ "t/cpan-changes.t" "t/pod-files-presence.t" "t/pod.t"
+ "t/release-kwalitee.t" "t/style-trailing-space.t"
+ "t/11memory.t"
+)
+
+src_compile() {
+ export SKIP_SAX_INSTALL=1
+ perl-module_src_compile
+}
+
+pkg_postinst() {
+ pkg_update_parser add XML::LibXML::SAX::Parser
+ pkg_update_parser add XML::LibXML::SAX
+}
+
+pkg_postrm() {
+ pkg_update_parser remove XML::LibXML::SAX::Parser
+ pkg_update_parser remove XML::LibXML::SAX
+}
+
+pkg_update_parser() {
+ # pkg_update_parser [add|remove] $parser_module
+ local action=$1
+ local parser_module=$2
+
+ if [[ "$ROOT" = "/" ]] ; then
+ einfo "Update Parser: $1 $2"
+ perl -MXML::SAX -e "XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()" \
+ || ewarn "Update Parser: $1 $2 failed"
+ else
+ elog "To $1 $2 run:"
+ elog "perl -MXML::SAX -e 'XML::SAX->${action}_parser(q(${parser_module}))->save_parsers()'"
+ fi
+}