summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-04-22 22:49:55 -0500
committerAaron Bauman <bman@gentoo.org>2018-04-23 10:37:11 -0400
commit7f9245390327c20e3bbed8a34d708c40f130ec88 (patch)
tree4413d52d94902fbbfab60fb0bd4e56ceddc1b6a0
parentnet-libs/libsrtp: drop vulnerable (diff)
downloadgentoo-7f9245390327c20e3bbed8a34d708c40f130ec88.tar.gz
gentoo-7f9245390327c20e3bbed8a34d708c40f130ec88.tar.bz2
gentoo-7f9245390327c20e3bbed8a34d708c40f130ec88.zip
sys-kernel/zen-sources: new versions, git-2->git-r3, EAPI=6
Bug: https://bugs.gentoo.org/653854 Package-Manager: Portage-2.3.31, Repoman-2.3.9 Closes: https://github.com/gentoo/gentoo/pull/8114
-rw-r--r--sys-kernel/zen-sources/zen-sources-4.14.9999.ebuild39
-rw-r--r--sys-kernel/zen-sources/zen-sources-4.15.9999.ebuild39
-rw-r--r--sys-kernel/zen-sources/zen-sources-4.16.9999.ebuild39
3 files changed, 117 insertions, 0 deletions
diff --git a/sys-kernel/zen-sources/zen-sources-4.14.9999.ebuild b/sys-kernel/zen-sources/zen-sources-4.14.9999.ebuild
new file mode 100644
index 000000000000..0f700b7c2674
--- /dev/null
+++ b/sys-kernel/zen-sources/zen-sources-4.14.9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+K_PREPATCHED="yes"
+UNIPATCH_STRICTORDER="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_DEBLOB_AVAILABLE=0
+CKV="${PV/99/}"
+
+ETYPE="sources"
+
+EGIT_BRANCH="${PV/.9999/}/master"
+EGIT_REPO_URI="https://github.com/zen-kernel/zen-kernel.git"
+
+inherit kernel-2 git-r3
+detect_version
+
+K_NOSETEXTRAVERSION="don't_set_it"
+DESCRIPTION="The Zen Kernel Live Sources"
+HOMEPAGE="https://zen-kernel.org"
+
+IUSE=""
+
+KEYWORDS=""
+
+EGIT_CHECKOUT_DIR="${WORKDIR}/linux-${KV_FULL}"
+
+K_EXTRAEINFO="For more info on zen-sources, and for how to report problems, see: \
+${HOMEPAGE}, also go to #zen-sources on freenode"
+
+pkg_setup(){
+ ewarn "Be carefull!! You are about to install live kernel sources."
+ ewarn "Git zen-sources are extremely unsupported, even from the upstream"
+ ewarn "developers. Use them at your own risk and don't bite us if your"
+ ewarn "system explodes"
+ kernel-2_pkg_setup
+}
diff --git a/sys-kernel/zen-sources/zen-sources-4.15.9999.ebuild b/sys-kernel/zen-sources/zen-sources-4.15.9999.ebuild
new file mode 100644
index 000000000000..0f700b7c2674
--- /dev/null
+++ b/sys-kernel/zen-sources/zen-sources-4.15.9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+K_PREPATCHED="yes"
+UNIPATCH_STRICTORDER="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_DEBLOB_AVAILABLE=0
+CKV="${PV/99/}"
+
+ETYPE="sources"
+
+EGIT_BRANCH="${PV/.9999/}/master"
+EGIT_REPO_URI="https://github.com/zen-kernel/zen-kernel.git"
+
+inherit kernel-2 git-r3
+detect_version
+
+K_NOSETEXTRAVERSION="don't_set_it"
+DESCRIPTION="The Zen Kernel Live Sources"
+HOMEPAGE="https://zen-kernel.org"
+
+IUSE=""
+
+KEYWORDS=""
+
+EGIT_CHECKOUT_DIR="${WORKDIR}/linux-${KV_FULL}"
+
+K_EXTRAEINFO="For more info on zen-sources, and for how to report problems, see: \
+${HOMEPAGE}, also go to #zen-sources on freenode"
+
+pkg_setup(){
+ ewarn "Be carefull!! You are about to install live kernel sources."
+ ewarn "Git zen-sources are extremely unsupported, even from the upstream"
+ ewarn "developers. Use them at your own risk and don't bite us if your"
+ ewarn "system explodes"
+ kernel-2_pkg_setup
+}
diff --git a/sys-kernel/zen-sources/zen-sources-4.16.9999.ebuild b/sys-kernel/zen-sources/zen-sources-4.16.9999.ebuild
new file mode 100644
index 000000000000..0f700b7c2674
--- /dev/null
+++ b/sys-kernel/zen-sources/zen-sources-4.16.9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+K_PREPATCHED="yes"
+UNIPATCH_STRICTORDER="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_DEBLOB_AVAILABLE=0
+CKV="${PV/99/}"
+
+ETYPE="sources"
+
+EGIT_BRANCH="${PV/.9999/}/master"
+EGIT_REPO_URI="https://github.com/zen-kernel/zen-kernel.git"
+
+inherit kernel-2 git-r3
+detect_version
+
+K_NOSETEXTRAVERSION="don't_set_it"
+DESCRIPTION="The Zen Kernel Live Sources"
+HOMEPAGE="https://zen-kernel.org"
+
+IUSE=""
+
+KEYWORDS=""
+
+EGIT_CHECKOUT_DIR="${WORKDIR}/linux-${KV_FULL}"
+
+K_EXTRAEINFO="For more info on zen-sources, and for how to report problems, see: \
+${HOMEPAGE}, also go to #zen-sources on freenode"
+
+pkg_setup(){
+ ewarn "Be carefull!! You are about to install live kernel sources."
+ ewarn "Git zen-sources are extremely unsupported, even from the upstream"
+ ewarn "developers. Use them at your own risk and don't bite us if your"
+ ewarn "system explodes"
+ kernel-2_pkg_setup
+}