summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2022-02-15 19:31:20 +0100
committerSebastian Pipping <sping@gentoo.org>2022-02-15 19:38:52 +0100
commit8008889058a0bafea3d5e9930604288fa9360a24 (patch)
tree7fed4007e375362833a9ed31571ae945fed2ab58
parentdev-php/pecl-amqp: Drop old version (diff)
downloadgentoo-8008889058a0bafea3d5e9930604288fa9360a24.tar.gz
gentoo-8008889058a0bafea3d5e9930604288fa9360a24.tar.bz2
gentoo-8008889058a0bafea3d5e9930604288fa9360a24.zip
dev-python/distro: 1.7.0
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.30, Repoman-3.0.3
-rw-r--r--dev-python/distro/Manifest1
-rw-r--r--dev-python/distro/distro-1.7.0.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/distro/Manifest b/dev-python/distro/Manifest
index 219e84da8697..0c91f82f175e 100644
--- a/dev-python/distro/Manifest
+++ b/dev-python/distro/Manifest
@@ -1 +1,2 @@
DIST distro-1.6.0.tar.gz 53518 BLAKE2B d60555488ed12658a3129747eed891487dfdf7f16b530b84c44cd976c6dcfadbeb9e20130e5c2eee9c71b0fd0c86c82d258a76498171f4e553c087840903e3b8 SHA512 d30334ed1137c54ddc70e041b75be905b7e13398483d0d92117eca0407d2a7b60424d96fd7af885a2e3ea3676b1aef620e91598a53309ae0da12a360d57ac013
+DIST distro-1.7.0.tar.gz 58164 BLAKE2B 22bbd2daf9cac589530eac9a58767db6b9e389b77719516f7386a9377b49ba4c9b696165701acc42366b760b9a632c70a2243a58c12a367fef2a0a770a4aea44 SHA512 14516ecab33ee8c57c35a8279eb515fd699031fabac7d8886092ea98696797d55503179870aeb513a85e1a66c7e69f2f60bb6ea9fc935be975cb5135e1917ecc
diff --git a/dev-python/distro/distro-1.7.0.ebuild b/dev-python/distro/distro-1.7.0.ebuild
new file mode 100644
index 000000000000..1bd6e7cedf53
--- /dev/null
+++ b/dev-python/distro/distro-1.7.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Reliable machine-readable Linux distribution information for Python"
+HOMEPAGE="
+ https://distro.readthedocs.io/en/latest/
+ https://pypi.org/project/distro/
+ https://github.com/python-distro/distro/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+distutils_enable_tests pytest