summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2022-02-27 18:27:21 -0500
committerMike Pagano <mpagano@gentoo.org>2022-02-27 18:27:21 -0500
commit80b836ff0a9a24c1a63ab867af708467c15dea15 (patch)
treecda3e34bffbebae0d97e12bc11085fdaf507ed69
parentapp-text/antiword: drop 0.37-r1 (diff)
downloadgentoo-80b836ff0a9a24c1a63ab867af708467c15dea15.tar.gz
gentoo-80b836ff0a9a24c1a63ab867af708467c15dea15.tar.bz2
gentoo-80b836ff0a9a24c1a63ab867af708467c15dea15.zip
Linux patch 5.17-rc6
Signed-off-by: Mike Pagano <mpagano@gentoo.org>
-rw-r--r--sys-kernel/git-sources/Manifest1
-rw-r--r--sys-kernel/git-sources/git-sources-5.17_rc6.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/git-sources/Manifest b/sys-kernel/git-sources/Manifest
index 2187a52576f4..4ac36f2d193b 100644
--- a/sys-kernel/git-sources/Manifest
+++ b/sys-kernel/git-sources/Manifest
@@ -4,3 +4,4 @@ DIST patch-5.17-rc2.patch 36928215 BLAKE2B 3ae1f09eeb870fda422db561ca1adfd68c7ea
DIST patch-5.17-rc3.patch 37376734 BLAKE2B 40564254d729bdad9860b48a51657b6a3cef681b9f4add643d7a7e8bd80511cc3da9ec7257acd355a23cde8f1c8e51286560a168ad951100c9139057518d64f6 SHA512 d5c6444f73a1d0099ed9c3f1c35e7d0e6df487b9897d57b5f9d4d787df210dd8a2fb58c428a13844c5c846007fe5f349860503187690ed83f846b867377d5cf1
DIST patch-5.17-rc4.patch 37600999 BLAKE2B f5839b3f9cf1c7ec4e49ae29d27525a9bce1f244fbfbd30b4b2f9b35761873e74d79a36e4ecb619ce91d04829164b8e347a3c23d66fbef677619f0f8e51498d2 SHA512 54a3e37bad6e223b09bebe97f5188cbbbc38ada271611d817aa2d033895c602bfb989fcd028004507a0ab5063af532d3f5a16424f574f24d78e6962eb460998c
DIST patch-5.17-rc5.patch 37807134 BLAKE2B 26624949169e5f64fd76394e9ef5850f0eb2d71acd562bc7e44db20e7ad3bd178747bfffa99c5d5c54c54c7ada563417e617a5d8e63b077e70b42effe2a825a3 SHA512 e0ce9cc3c1bd1584d59d747f6419c54654d9be0ced307f2328f04ca1684c74e32e38b3dbabc292fffef87ab1813e4e3e0321f3a1e2d971b4cac81577f07ac0f3
+DIST patch-5.17-rc6.patch 38063544 BLAKE2B 7a57f1ae851fecfd89e2ad47e92b0c581ec166f42f3faec1986991d3629b7c48746c411b6b0f9cf2d1534c11a4d8560261cd236c8279561c6ee32030713c63f8 SHA512 f6c26d604db0db15678c866ad30d6d8b2ebd7fde66064e71d048080e20d26c4050a224d94917d5e1deff2a27c5607fc41440af6dbb3cc68d3043b3f8460b5f18
diff --git a/sys-kernel/git-sources/git-sources-5.17_rc6.ebuild b/sys-kernel/git-sources/git-sources-5.17_rc6.ebuild
new file mode 100644
index 000000000000..b7eedd7884ba
--- /dev/null
+++ b/sys-kernel/git-sources/git-sources-5.17_rc6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+UNIPATCH_STRICTORDER="yes"
+K_NOUSENAME="yes"
+K_NOSETEXTRAVERSION="yes"
+K_NOUSEPR="yes"
+K_SECURITY_UNSUPPORTED="1"
+K_BASE_VER="5.16"
+K_EXP_GENPATCHES_NOUSE="1"
+K_FROM_GIT="yes"
+ETYPE="sources"
+CKV="${PVR/-r/-git}"
+
+# only use this if it's not an _rc/_pre release
+[ "${PV/_pre}" == "${PV}" ] && [ "${PV/_rc}" == "${PV}" ] && OKV="${PV}"
+inherit kernel-2
+detect_version
+
+DESCRIPTION="The very latest -git version of the Linux kernel"
+HOMEPAGE="https://www.kernel.org"
+SRC_URI="${KERNEL_URI}"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE=""
+
+K_EXTRAEINFO="This kernel is not supported by Gentoo due to its unstable and
+experimental nature. If you have any issues, try a matching vanilla-sources
+ebuild -- if the problem is not there, please contact the upstream kernel
+developers at https://bugzilla.kernel.org and on the linux-kernel mailing list to
+report the problem so it can be fixed in time for the next kernel release."
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ >=sys-devel/patch-2.7.6-r4"
+
+pkg_postinst() {
+ postinst_sources
+}