summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2015-09-30 13:21:09 +0200
committerAlexis Ballier <aballier@gentoo.org>2015-09-30 14:03:50 +0200
commit8180f9d39f5f4c2dcc0707b082cd14b493fc7b2a (patch)
treebea2043a0d6259113cc902be38627aab1cfea323
parentdev-ros/nav_core: Initial import. Ebuild by me. (diff)
downloadgentoo-8180f9d39f5f4c2dcc0707b082cd14b493fc7b2a.tar.gz
gentoo-8180f9d39f5f4c2dcc0707b082cd14b493fc7b2a.tar.bz2
gentoo-8180f9d39f5f4c2dcc0707b082cd14b493fc7b2a.zip
dev-ros/navfn: Initial import. Ebuild by me.
Package-Manager: portage-2.2.22
-rw-r--r--dev-ros/navfn/Manifest1
-rw-r--r--dev-ros/navfn/files/pgm_h_location.patch26
-rw-r--r--dev-ros/navfn/metadata.xml5
-rw-r--r--dev-ros/navfn/navfn-1.13.0.ebuild36
-rw-r--r--dev-ros/navfn/navfn-9999.ebuild36
5 files changed, 104 insertions, 0 deletions
diff --git a/dev-ros/navfn/Manifest b/dev-ros/navfn/Manifest
new file mode 100644
index 000000000000..2ab0c74f2366
--- /dev/null
+++ b/dev-ros/navfn/Manifest
@@ -0,0 +1 @@
+DIST navigation-1.13.0.tar.gz 336419 SHA256 5ef288325a0de4accfb4ef0cc37d9e9c4106a05d98b0ae5757f6c4823abada97 SHA512 1b686d4d1e930901dcf899fb73c8609855c3bb6d797322f6f3b9ea7ccb349f98802870b44e0fcbee4e68abebeecbaff57d453dc790fbc908cd23b8afda22e1af WHIRLPOOL 096103d8b774205995a12d294c820187fb89302285b363f6e6b9a4bb1e30a2edf9b33a451effc00b8aeec4d8f40664f61266314d389b9c668c0d7cf2152f70dd
diff --git a/dev-ros/navfn/files/pgm_h_location.patch b/dev-ros/navfn/files/pgm_h_location.patch
new file mode 100644
index 000000000000..683a9556ddc0
--- /dev/null
+++ b/dev-ros/navfn/files/pgm_h_location.patch
@@ -0,0 +1,26 @@
+Index: navigation-1.13.0/navfn/src/navtest.cpp
+===================================================================
+--- navigation-1.13.0.orig/navfn/src/navtest.cpp
++++ navigation-1.13.0/navfn/src/navtest.cpp
+@@ -21,7 +21,7 @@ using namespace navfn;
+ extern "C" {
+ #include <stdio.h>
+ // pgm.h is not very friendly with system headers... need to undef max() and min() afterwards
+-#include <pgm.h>
++#include <netpbm/pgm.h>
+ #undef max
+ #undef min
+ }
+Index: navigation-1.13.0/navfn/src/read_pgm_costmap.cpp
+===================================================================
+--- navigation-1.13.0.orig/navfn/src/read_pgm_costmap.cpp
++++ navigation-1.13.0/navfn/src/read_pgm_costmap.cpp
+@@ -37,7 +37,7 @@
+ extern "C" {
+ #include <stdio.h>
+ // pgm.h is not very friendly with system headers... need to undef max() and min() afterwards
+-#include <pgm.h>
++#include <netpbm/pgm.h>
+ #undef max
+ #undef min
+ }
diff --git a/dev-ros/navfn/metadata.xml b/dev-ros/navfn/metadata.xml
new file mode 100644
index 000000000000..c42ea5b15cf6
--- /dev/null
+++ b/dev-ros/navfn/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/navfn/navfn-1.13.0.ebuild b/dev-ros/navfn/navfn-1.13.0.ebuild
new file mode 100644
index 000000000000..bea902da7af6
--- /dev/null
+++ b/dev-ros/navfn/navfn-1.13.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs dev-ros/nav_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Fast interpolated navigation function that can be used to create plans for a mobile base"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/costmap_2d
+ dev-ros/nav_core
+ dev-ros/pcl_conversions
+ dev-ros/pcl_ros
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/visualization_msgs
+ dev-cpp/eigen:3
+ sci-libs/pcl
+ x11-libs/fltk
+ media-libs/netpbm
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )
+ dev-ros/cmake_modules"
+
+PATCHES=( "${FILESDIR}/pgm_h_location.patch" )
diff --git a/dev-ros/navfn/navfn-9999.ebuild b/dev-ros/navfn/navfn-9999.ebuild
new file mode 100644
index 000000000000..bea902da7af6
--- /dev/null
+++ b/dev-ros/navfn/navfn-9999.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros-planning/navigation"
+ROS_SUBDIR=${PN}
+KEYWORDS="~amd64 ~arm"
+CATKIN_MESSAGES_TRANSITIVE_DEPS="dev-ros/std_msgs dev-ros/geometry_msgs dev-ros/nav_msgs"
+
+inherit ros-catkin
+
+DESCRIPTION="Fast interpolated navigation function that can be used to create plans for a mobile base"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ dev-ros/costmap_2d
+ dev-ros/nav_core
+ dev-ros/pcl_conversions
+ dev-ros/pcl_ros
+ dev-ros/pluginlib
+ dev-ros/roscpp
+ dev-ros/tf
+ dev-ros/visualization_msgs
+ dev-cpp/eigen:3
+ sci-libs/pcl
+ x11-libs/fltk
+ media-libs/netpbm
+"
+DEPEND="${RDEPEND}
+ test? ( dev-cpp/gtest )
+ dev-ros/cmake_modules"
+
+PATCHES=( "${FILESDIR}/pgm_h_location.patch" )