summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Ogilvie <mmogilvi+gnto@zoho.com>2020-12-23 13:16:15 -0700
committerJoonas Niilola <juippis@gentoo.org>2021-01-18 11:27:37 +0200
commit8186e14efd61d97cdac690d3c1d8a637eb70b0a7 (patch)
tree7864e896572e26bb3f5f505157fd774130834908
parentwww-servers/caddy: version bump to 2.2.3 (diff)
downloadgentoo-8186e14efd61d97cdac690d3c1d8a637eb70b0a7.tar.gz
gentoo-8186e14efd61d97cdac690d3c1d8a637eb70b0a7.tar.bz2
gentoo-8186e14efd61d97cdac690d3c1d8a637eb70b0a7.zip
net-mail/poppassd_ceti: bump 1.8.9
This works properly in my existing sudo-based installation. However, upstream (and this ebuild) has added new LDAP support and systemd unit files, and I don't have an environment to test either. Bug: https://bugs.gentoo.org/145839 Signed-off-by: Matthew Ogilvie <mmogilvi+gnto@zoho.com> Closes: https://github.com/gentoo/gentoo/pull/18795 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--net-mail/poppassd_ceti/Manifest1
-rw-r--r--net-mail/poppassd_ceti/poppassd_ceti-1.8.9.ebuild65
2 files changed, 66 insertions, 0 deletions
diff --git a/net-mail/poppassd_ceti/Manifest b/net-mail/poppassd_ceti/Manifest
index a7b79b5b06e8..9902ccd8d789 100644
--- a/net-mail/poppassd_ceti/Manifest
+++ b/net-mail/poppassd_ceti/Manifest
@@ -1 +1,2 @@
DIST poppassd-ceti-1.8.7.tar.xz 71400 BLAKE2B ca26f7298a8f679c595a9cd66622f1e8ddeff80a7b1655df91a7a15668337112113806d0aef788a374c483cbc957e765b178428d839da2c853ebf87e16039548 SHA512 d50549a4f6bdd9eac7fa74a7787e47dbffff14da883d4e8e23e24802883761c1a392b8a7fbffe5fa726845f48b3b33e0dbc1743ad2d689a4d396c91d0a42f8f1
+DIST poppassd-ceti-1.8.9.tar.gz 15465 BLAKE2B 22f6b521d83c4b7c4a8842cde22710c17dda26f9cbfb39d020de05b14c045a1606fcebf51557c2e38c932e009554c5f0d1f770d5cfbf1666f81eb03a342c25f4 SHA512 cc8953aaed8cd6d2633d1c2040e364770598eb71d563a29fd3f4798730654d002ba720babab0596cc336ea8aff403064e17e8b17c3df657e5c840db2230a2077
diff --git a/net-mail/poppassd_ceti/poppassd_ceti-1.8.9.ebuild b/net-mail/poppassd_ceti/poppassd_ceti-1.8.9.ebuild
new file mode 100644
index 000000000000..0d8585f2854f
--- /dev/null
+++ b/net-mail/poppassd_ceti/poppassd_ceti-1.8.9.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_IN_SOURCE_BUILD=1
+inherit cmake pam readme.gentoo-r1 systemd
+
+# Long ago it was just "poppassd", but upstream now seems to have
+# settled on "poppassd-ceti" (instead of "poppassd_ceti" or no suffix).
+MY_PN="poppassd-ceti"
+MY_P="${MY_PN}-${PV}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Password change daemon with PAM support"
+HOMEPAGE="https://github.com/kravietz/poppassd-ceti"
+SRC_URI="https://github.com/kravietz/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="sys-libs/pam"
+RDEPEND="${DEPEND}"
+
+DISABLE_AUTOFORMATTING=1
+DOC_CONTENTS="poppassd is installed, but has to be run as root to work.
+
+Most commonly a front end would require sys-apps/xinetd and connect to
+port 106: For this, edit /etc/xinetd.d/poppassd, install sys-apps/xinetd,
+and start the xinetd service.
+
+If you use systemd, you may be able to use the installed poppassd.socket
+and poppassd.service files instead of xinetd. See README.md.bz2 and
+systemd documentation.
+
+Alternatively, a front end may be able to run it directly (if already
+root), or might use app-admin/sudo. To use sudo, you'll need to configure
+/etc/sudoers with something similar to:
+
+ apache ALL=(ALL) NOPASSWD: /usr/sbin/poppassd
+
+See also README.md.bz2 for related configuration and security
+considerations.
+"
+
+src_install() {
+ dodoc README.md
+ readme.gentoo_create_doc
+
+ pamd_mimic_system poppassd auth account password
+
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/poppassd.xinetd poppassd
+
+ systemd_dounit etc/systemd/poppassd.{socket,service}
+
+ exeinto /usr/sbin
+ exeopts -o root -g bin -m 500
+ doexe poppassd
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}