summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-04-18 00:29:32 +0200
committerDavid Seifert <soap@gentoo.org>2020-04-18 00:29:32 +0200
commit818dc9a671056757ee3743dc1d509fbe5c6abcdc (patch)
tree35adf2321808b4c0650abfb231840691bfb699a6
parentdev-python/pysnmp: Add py3.8 (diff)
downloadgentoo-818dc9a671056757ee3743dc1d509fbe5c6abcdc.tar.gz
gentoo-818dc9a671056757ee3743dc1d509fbe5c6abcdc.tar.bz2
gentoo-818dc9a671056757ee3743dc1d509fbe5c6abcdc.zip
net-p2p/bittornado: Remove old
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--net-p2p/bittornado/Manifest1
-rw-r--r--net-p2p/bittornado/bittornado-0.3.18-r4.ebuild56
-rw-r--r--net-p2p/bittornado/files/bittornado-0.3.18-wxversion.patch90
3 files changed, 0 insertions, 147 deletions
diff --git a/net-p2p/bittornado/Manifest b/net-p2p/bittornado/Manifest
index 4e8b2ed3003..ebfe3739acc 100644
--- a/net-p2p/bittornado/Manifest
+++ b/net-p2p/bittornado/Manifest
@@ -1,2 +1 @@
-DIST BitTornado-0.3.18.tar.gz 189227 BLAKE2B 96a273c6f1072a19a0853cb0f0c16165432670927588f3422e680580e7d31a76b1b06b8e8a806676eb2f0cdfe0d4c785c389f07cb7a4690feb57cbac9c45c28f SHA512 61a55726d93ddb245e18e47f41dea982b8faa7d3296c3a7221d00e0fe71db772613c3ee113bb7df18390807dda8c77859ed7159a03535446ca417a1344e3c0d6
DIST BitTornado-0.4.1_p20160925.tar.gz 164352 BLAKE2B 34cebe27ab0cb18a960ef830311ffa47f2064c83768a9a011dcd9e45e9460b60438e159824eaf9cf844d7c5604a9de832e6a85cea3335d9e6223c31e7b349014 SHA512 09971cc5705c421c4440cd51b9aa37da9f8ce992a882d342c0547fe1771199fa61c4924f6d6cd321776f9dcefafd3e244b9cbfce047c4cdd4502dd0a1a1fdaaa
diff --git a/net-p2p/bittornado/bittornado-0.3.18-r4.ebuild b/net-p2p/bittornado/bittornado-0.3.18-r4.ebuild
deleted file mode 100644
index fe11296fb4d..00000000000
--- a/net-p2p/bittornado/bittornado-0.3.18-r4.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-# note: wxGTK interface has been removed wrt #391685. this ebuild is only for
-# cmdline tools as is.
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-MY_PN=BitTornado
-MY_P=${MY_PN}-${PV}
-
-DESCRIPTION="TheShad0w's experimental BitTorrent client"
-HOMEPAGE="http://www.bittornado.com/"
-SRC_URI="http://download2.bittornado.com/download/${MY_P}.tar.gz"
-# GPL-2 is just for the init script from FILESDIR.
-LICENSE="MIT GPL-2"
-SLOT="0"
-
-KEYWORDS="~alpha amd64 ~hppa ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE=""
-
-RDEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- app-arch/unzip
- >=sys-apps/sed-4.0.5"
-
-S=${WORKDIR}/${MY_PN}-CVS
-PIXMAPLOC=/usr/share/pixmaps/bittornado
-
-python_prepare_all() {
- # fixes wrong icons path
- sed -i "s:os.path.abspath(os.path.dirname(os.path.realpath(sys.argv\[0\]))):\"${PIXMAPLOC}/\":" btdownloadgui.py
- # Needs wxpython-2.6 only, bug #201247
- eapply "${FILESDIR}"/${P}-wxversion.patch
-
- distutils-r1_python_prepare_all
-}
-
-python_install() {
- distutils-r1_python_install
-
- # get rid of any reference to the not-installed gui version
- rm "${ED%/}"/usr/bin/*gui.py || die
- rm "${D}/$(python_get_scriptdir)"/*gui.py || die
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- newconfd "${FILESDIR}"/bttrack.conf bttrack
- newinitd "${FILESDIR}"/bttrack.rc bttrack
-}
diff --git a/net-p2p/bittornado/files/bittornado-0.3.18-wxversion.patch b/net-p2p/bittornado/files/bittornado-0.3.18-wxversion.patch
deleted file mode 100644
index 35739630348..00000000000
--- a/net-p2p/bittornado/files/bittornado-0.3.18-wxversion.patch
+++ /dev/null
@@ -1,90 +0,0 @@
-diff -Naur BitTornado-CVS-orig/btcompletedirgui.py BitTornado-CVS/btcompletedirgui.py
---- BitTornado-CVS-orig/btcompletedirgui.py 2006-12-23 12:20:52.000000000 -0600
-+++ BitTornado-CVS/btcompletedirgui.py 2007-12-04 11:09:36.000000000 -0600
-@@ -19,12 +19,16 @@
- import sys
- from os import getcwd
- from os.path import join
-+
- try:
-- from wxPython.wx import *
--except:
-- print 'wxPython is either not installed or has not been installed properly.'
-+ import wxversion
-+ wxversion.select("2.6")
-+except Exception, e:
-+ print >> sys.stderr, "%s: wxPython 2.6 not installed." %e
- sys.exit(1)
-
-+from wxPython.wx import *
-+
- try:
- True
- except:
-diff -Naur BitTornado-CVS-orig/btdownloadgui.py BitTornado-CVS/btdownloadgui.py
---- BitTornado-CVS-orig/btdownloadgui.py 2007-12-04 11:06:58.000000000 -0600
-+++ BitTornado-CVS/btdownloadgui.py 2007-12-04 11:10:36.000000000 -0600
-@@ -18,10 +18,13 @@
- assert version >= '2', "Install Python 2.0 or greater"
-
- try:
-- from wxPython.wx import *
--except:
-- print 'wxPython is either not installed or has not been installed properly.'
-- exit(1)
-+ import wxversion
-+ wxversion.select("2.6")
-+except Exception, e:
-+ print >> sys.stderr, "%s: wxPython 2.6 not installed." %e
-+ sys.exit(1)
-+
-+from wxPython.wx import *
- from BitTornado.download_bt1 import BT1Download, defaults, parse_params, get_usage, get_response
- from BitTornado.RawServer import RawServer, UPnP_ERROR
- from random import seed
-diff -Naur BitTornado-CVS-orig/btmaketorrentgui.py BitTornado-CVS/btmaketorrentgui.py
---- BitTornado-CVS-orig/btmaketorrentgui.py 2006-12-23 12:20:56.000000000 -0600
-+++ BitTornado-CVS/btmaketorrentgui.py 2007-12-04 11:11:30.000000000 -0600
-@@ -21,12 +21,16 @@
- import sys
- from os import getcwd
- from os.path import join, isdir
-+
- try:
-- from wxPython.wx import *
--except:
-- print 'wxPython is either not installed or has not been installed properly.'
-+ import wxversion
-+ wxversion.select("2.6")
-+except Exception, e:
-+ print >> sys.stderr, "%s: wxPython 2.6 not installed." %e
- sys.exit(1)
-
-+from wxPython.wx import *
-+
- try:
- True
- except:
-diff -Naur BitTornado-CVS-orig/bt-t-make.py BitTornado-CVS/bt-t-make.py
---- BitTornado-CVS-orig/bt-t-make.py 2006-12-23 12:20:52.000000000 -0600
-+++ BitTornado-CVS/bt-t-make.py 2007-12-04 11:14:35.000000000 -0600
-@@ -22,12 +22,16 @@
- from os import getcwd, listdir
- from os.path import join, isdir
- from traceback import print_exc
-+
- try:
-- from wxPython.wx import *
--except:
-- print 'wxPython is either not installed or has not been installed properly.'
-+ import wxversion
-+ wxversion.select("2.6")
-+except Exception, e:
-+ print >> sys.stderr, "%s: wxPython 2.6 not installed." %e
- sys.exit(1)
-
-+from wxPython.wx import *
-+
- try:
- True
- except: