summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-09-24 11:17:40 -0400
committerMatt Turner <mattst88@gentoo.org>2022-09-24 11:33:43 -0400
commit81e6a9abfb15f19c1004000430b05297954f5ddd (patch)
treecb3bf42c7aa1b467a13711c80f056ba5bdb9e362
parentmedia-gfx/simple-scan: Version bump to 42.5 (diff)
downloadgentoo-81e6a9abfb15f19c1004000430b05297954f5ddd.tar.gz
gentoo-81e6a9abfb15f19c1004000430b05297954f5ddd.tar.bz2
gentoo-81e6a9abfb15f19c1004000430b05297954f5ddd.zip
net-libs/glib-networking: Version bump to 2.74.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--net-libs/glib-networking/Manifest1
-rw-r--r--net-libs/glib-networking/glib-networking-2.74.0.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/net-libs/glib-networking/Manifest b/net-libs/glib-networking/Manifest
index 901f3d903c4b..31d61b544efa 100644
--- a/net-libs/glib-networking/Manifest
+++ b/net-libs/glib-networking/Manifest
@@ -1,2 +1,3 @@
DIST glib-networking-2.72.1.tar.xz 265308 BLAKE2B 84264df5e094a4c57d86edd57fdedb11ad00eec5937eb056de34ec3d38a0e0e2ec3d71a5ad4ab0386c45681c8784b792ca6ded9c048d93c3ed1ad47d2f31f44e SHA512 243f54f4fbce40211f276c4f56e4e40507ecb0b23527a04b2d5bd67185c017f736f088c71ebf225e69e1ae8efa5b835edd68ea5c96df3ff69a25fd391e5c52d0
DIST glib-networking-2.72.2.tar.xz 265268 BLAKE2B 90e6eee44faeb495e26a61d15fab66034784637f43d2184901099a6daa69e36d39f732cd5ccd5262f213f19329982264138592b60a08009f4ff034a3ad20922a SHA512 b2837f1521ea8312fb508d3000d465898d409bb48033a63430609331f45628f6b49eaaf16278f2ef48c41b9fccf38f78a85374d23e9ea75692a11cbd7ef058ec
+DIST glib-networking-2.74.0.tar.xz 277232 BLAKE2B d0027a3beff276b2d0b008d1ed0bdeef231d8fb03c26c2e301a3eaef76ad4b704a5db36f6265c5516d73c5dbdb98c7c0919b6924038506dad0123f5ec77577b2 SHA512 f266c106f2c9379b95773a852c1b5c62ae1d6a758d25c436c3558f620d8e0a211201b3c4dfd89cdbe28b88430bba0cca621e62c01ea23d473983e203919bb1e6
diff --git a/net-libs/glib-networking/glib-networking-2.74.0.ebuild b/net-libs/glib-networking/glib-networking-2.74.0.ebuild
new file mode 100644
index 000000000000..daa6560dc62e
--- /dev/null
+++ b/net-libs/glib-networking/glib-networking-2.74.0.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org gnome2-utils meson-multilib xdg
+
+DESCRIPTION="Network-related giomodules for glib"
+HOMEPAGE="https://gitlab.gnome.org/GNOME/glib-networking"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="+gnome +libproxy +ssl test"
+RESTRICT="!test? ( test )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ >=dev-libs/glib-2.73.3:2[${MULTILIB_USEDEP}]
+ libproxy? ( >=net-libs/libproxy-0.4.16:=[${MULTILIB_USEDEP}] )
+ >=net-libs/gnutls-3.7.4:=[${MULTILIB_USEDEP}]
+ ssl? ( app-misc/ca-certificates )
+ gnome? ( gnome-base/gsettings-desktop-schemas )
+"
+DEPEND="${RDEPEND}
+ test? ( net-libs/gnutls[pkcs11] )
+"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ test? ( sys-apps/dbus )
+"
+
+src_prepare() {
+ default
+ xdg_environment_reset
+
+ if ! use test ; then
+ # Don't build tests unconditionally
+ # This is a hack to avoid needing gnutls[pkcs11] when USE=-test
+ # It may become a real runtime dependency in future
+ # Please check!
+ # bug #777462
+ sed -i "/^subdir('tests')/d" tls/meson.build || die
+ fi
+}
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dgnutls=enabled
+ -Dopenssl=disabled
+ $(meson_feature !libproxy environment_proxy)
+ $(meson_feature libproxy)
+ $(meson_feature gnome gnome_proxy)
+ -Dinstalled_tests=false
+ -Ddebug_logs=false
+ )
+ meson_src_configure
+}
+
+multilib_src_test() {
+ dbus-run-session meson test -C "${BUILD_DIR}" || die 'tests failed'
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+
+ multilib_pkg_postinst() {
+ gnome2_giomodule_cache_update \
+ || die "Update GIO modules cache failed (for ${ABI})"
+ }
+ multilib_foreach_abi multilib_pkg_postinst
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+
+ multilib_pkg_postrm() {
+ gnome2_giomodule_cache_update \
+ || die "Update GIO modules cache failed (for ${ABI})"
+ }
+ multilib_foreach_abi multilib_pkg_postrm
+}