summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-04-01 13:13:04 +0300
committerViorel Munteanu <ceamac@gentoo.org>2023-04-02 12:59:14 +0300
commit820b9ba10ac262c2e8eadf8b550c0d9c341cf973 (patch)
tree37a7f4668128723b7163d5eb800c726c01189af8
parentdev-libs/xapian-bindings: add 1.4.22 (diff)
downloadgentoo-820b9ba10ac262c2e8eadf8b550c0d9c341cf973.tar.gz
gentoo-820b9ba10ac262c2e8eadf8b550c0d9c341cf973.tar.bz2
gentoo-820b9ba10ac262c2e8eadf8b550c0d9c341cf973.zip
app-text/xapian-omega: add 1.4.22
Closes: https://bugs.gentoo.org/729592 Closes: https://github.com/gentoo/gentoo/pull/30430 Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
-rw-r--r--app-text/xapian-omega/Manifest1
-rw-r--r--app-text/xapian-omega/xapian-omega-1.4.22.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-text/xapian-omega/Manifest b/app-text/xapian-omega/Manifest
index 892fdc707206..98ec25ec06e7 100644
--- a/app-text/xapian-omega/Manifest
+++ b/app-text/xapian-omega/Manifest
@@ -1,2 +1,3 @@
DIST xapian-omega-1.4.19.tar.xz 553680 BLAKE2B 1008376d2ba6d72d3cc267ee3bda78a1d37491d706417010e0f4ca7dddf78ddd3d9ad07108874eabfffd0280016ce1fad49c86ee89eed9b37ae571586f838c9b SHA512 82b682bc9d244256afffc2ab1b12b0f577184296a979dc42b2865b689c6d46eca6b838b95a5d040dc228de0c2e2261e81279e0a748eaff2d018732ce4bc07fae
DIST xapian-omega-1.4.21.tar.xz 568440 BLAKE2B 445152c23f58471402d8017906083123c0a0e55eb8feed8908dae46680148471a65c51ef146c693cbbb807ce7a70d6589c0a77c2508c39417b95f292d5e8b9f1 SHA512 a313725084c3c336655a3beaa2c1e6c9186027bf6c90f0c5261f748a08e1e8d1ef9d43b0c6bad5bbd5a5af9d1f3db49b915435e5e815f9e97d452590522e85ec
+DIST xapian-omega-1.4.22.tar.xz 570476 BLAKE2B 05bd5c8135870b3a2058bcd032da9609cac7d0b1a07b31cb84f8fdf175bb87d22acd9beb392f93ebf1f23e4ebf4d23fbe12b70063628d318012b71246d14f26b SHA512 460120fa2c76ad99f818f4183c4ded92eaa7f01a9dd782af1e93faf11caf2479053f45a9e9f0a602bf31631dba8be2d2c18bba28340c578126e8658ad4937c19
diff --git a/app-text/xapian-omega/xapian-omega-1.4.22.ebuild b/app-text/xapian-omega/xapian-omega-1.4.22.ebuild
new file mode 100644
index 000000000000..a9a75d694991
--- /dev/null
+++ b/app-text/xapian-omega/xapian-omega-1.4.22.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+HOMEPAGE="https://xapian.org/"
+DESCRIPTION="An application built on Xapian, consisting of indexers and a CGI search frontend"
+SRC_URI="https://oligarchy.co.uk/xapian/${PV}/xapian-omega-${PV}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+DEPEND="
+ dev-lang/perl
+ dev-libs/libpcre2:=
+ ~dev-libs/xapian-${PV}:0/30
+ sys-apps/file
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}" install
+
+ # Protect /etc/omega.conf
+ echo "CONFIG_PROTECT=\"/etc/omega.conf\"" > "${T}"/20xapian-omega || die
+ doenvd "${T}"/20xapian-omega
+ dodoc AUTHORS ChangeLog INSTALL NEWS README TODO
+
+ # Directory containing Xapian databases:
+ keepdir /var/lib/omega/data
+
+ # Directory containing OmegaScript templates:
+ keepdir /var/lib/omega/templates
+ mv "${S}"/templates/* "${ED}"/var/lib/omega/templates || die
+
+ # Directory to write Omega logs to:
+ keepdir /var/log/omega
+
+ # Directory containing any cdb files for the $lookup OmegaScript command:
+ keepdir /var/lib/omega/cdb
+}