summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2016-10-21 00:51:29 +0300
committerDavid Seifert <soap@gentoo.org>2016-10-21 01:39:17 +0200
commit8238093ef645e6b0f9e985a736c230aa2fec9af7 (patch)
tree09c7bca4c445cf6da546d5a8f1c8d0eaef9abaaf
parentmedia-libs/ffmpegsource: verbump to 2.23 (diff)
downloadgentoo-8238093ef645e6b0f9e985a736c230aa2fec9af7.tar.gz
gentoo-8238093ef645e6b0f9e985a736c230aa2fec9af7.tar.bz2
gentoo-8238093ef645e6b0f9e985a736c230aa2fec9af7.zip
media-video/mpv: do compiler checks in pkg_setup() too
Also reorder compiler check conditions for clarity. Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--media-video/mpv/mpv-9999.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/media-video/mpv/mpv-9999.ebuild b/media-video/mpv/mpv-9999.ebuild
index 950092a5a9fa..3e2347f8ae64 100644
--- a/media-video/mpv/mpv-9999.ebuild
+++ b/media-video/mpv/mpv-9999.ebuild
@@ -128,12 +128,21 @@ RDEPEND="${COMMON_DEPEND}
PATCHES=( "${FILESDIR}/${PN}-0.19.0-make-ffmpeg-version-check-non-fatal.patch" )
-pkg_pretend() {
- if [[ ${MERGE_TYPE} != "binary" ]] && ! tc-has-tls && use vaapi && use egl; then
+mpv_check_compiler() {
+ if [[ ${MERGE_TYPE} != "binary" ]] && use vaapi && use egl && ! tc-has-tls; then
die "Your compiler lacks C++11 TLS support. Use GCC>=4.8.0 or Clang>=3.3."
fi
}
+pkg_pretend() {
+ mpv_check_compiler
+}
+
+pkg_setup() {
+ mpv_check_compiler
+ python-any-r1_pkg_setup
+}
+
src_prepare() {
cp "${DISTDIR}/waf-${WAF_PV}" "${S}"/waf || die
chmod +x "${S}"/waf || die