summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-07-06 08:52:51 +0200
committerHans de Graaff <graaff@gentoo.org>2021-07-06 08:56:47 +0200
commit829ac0b41022fa2e3b951ea10f5948a5d78f25f9 (patch)
treed905d9eda24b83ec6ea703b60aeb6fedba17cd47
parentdev-ruby/em-websocket: cleanup (diff)
downloadgentoo-829ac0b41022fa2e3b951ea10f5948a5d78f25f9.tar.gz
gentoo-829ac0b41022fa2e3b951ea10f5948a5d78f25f9.tar.bz2
gentoo-829ac0b41022fa2e3b951ea10f5948a5d78f25f9.zip
dev-ruby/simpleidn: initial import of 0.2.1
New dependency for dev-ruby/dnsruby. Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/simpleidn/Manifest1
-rw-r--r--dev-ruby/simpleidn/metadata.xml11
-rw-r--r--dev-ruby/simpleidn/simpleidn-0.2.1.ebuild31
3 files changed, 43 insertions, 0 deletions
diff --git a/dev-ruby/simpleidn/Manifest b/dev-ruby/simpleidn/Manifest
new file mode 100644
index 000000000000..afdfc0ee83d1
--- /dev/null
+++ b/dev-ruby/simpleidn/Manifest
@@ -0,0 +1 @@
+DIST simpleidn-0.2.1.tar.gz 204644 BLAKE2B 4c7f82af2ddaa753c8df91f80776b2b00d3a8a8dfda95c9012ebc3e5eea6503fbb0f20a7f79f8c624612e433b0e61cec79bc6a147ef6a04d418cbff72c31c867 SHA512 20a81ea5bca503b167cd2183f762993454a5f7fe082639b70234521f8cb9e4533b1f5f22dfcac18108c90a461185b13fea55f6197ab4c5996116ac359adf5033
diff --git a/dev-ruby/simpleidn/metadata.xml b/dev-ruby/simpleidn/metadata.xml
new file mode 100644
index 000000000000..6668e58af2c4
--- /dev/null
+++ b/dev-ruby/simpleidn/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ruby@gentoo.org</email>
+ <name>Gentoo Ruby Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">mmriis/simpleidn</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/simpleidn/simpleidn-0.2.1.ebuild b/dev-ruby/simpleidn/simpleidn-0.2.1.ebuild
new file mode 100644
index 000000000000..f446bb84e2af
--- /dev/null
+++ b/dev-ruby/simpleidn/simpleidn-0.2.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby25 ruby26 ruby27"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+RUBY_FAKEGEM_EXTRAINSTALL="tables"
+
+RUBY_FAKEGEM_GEMSPEC="simpleidn.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Allows easy conversion from punycode ACE to unicode UTF-8 strings and vice-versa"
+HOMEPAGE="https://github.com/mmriis/simpleidn"
+SRC_URI="https://github.com/mmriis/simpleidn/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+KEYWORDS="~amd64"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+ruby_add_rdepend ">=dev-ruby/unf-0.1.4 =dev-ruby/unf-0.1*"
+
+all_ruby_prepare() {
+ sed -i -e '/simplecov/I s:^:#:' spec/spec_helper.rb || die
+ sed -i -e 's/git ls-files -z/find * -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}