summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-06-26 14:55:32 +0200
committerGöktürk Yüksek <gokturk@gentoo.org>2016-06-27 08:51:02 -0400
commit82c54423bf0ea24eb6cd4f43bca6f8e44c238c92 (patch)
tree85c5dbeb17cdf216f8349a522ac42c7925a78b9e
parentdev-python/jaraco-classes: remove old (diff)
downloadgentoo-82c54423bf0ea24eb6cd4f43bca6f8e44c238c92.tar.gz
gentoo-82c54423bf0ea24eb6cd4f43bca6f8e44c238c92.tar.bz2
gentoo-82c54423bf0ea24eb6cd4f43bca6f8e44c238c92.zip
dev-python/jaraco-stream: bump to 1.1.1
Package-Manager: portage-2.3.0_rc1
-rw-r--r--dev-python/jaraco-stream/Manifest1
-rw-r--r--dev-python/jaraco-stream/jaraco-stream-1.1.1.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/jaraco-stream/Manifest b/dev-python/jaraco-stream/Manifest
index 9034a69288ed..7c7ebddb57a4 100644
--- a/dev-python/jaraco-stream/Manifest
+++ b/dev-python/jaraco-stream/Manifest
@@ -1 +1,2 @@
+DIST jaraco.stream-1.1.1.tar.gz 6115 SHA256 f111cbb2a04063bcb1675a31a633c1a0f1b879a3f46c2ea8e71c7dc1242d8f47 SHA512 65c8d1652a0d63506cc3cadee590664e6a99e2f770d26f0cea1dce07c54ffe308e1df8619bc728ea81c5ac43c9c6731fe9f71e5d38d2674c4e0d63d635bb5112 WHIRLPOOL 808c4c854eea1f06bd8b06cdf31497876ccfeb939beb1c785408d83255774fd304d355e97ea7c4ff6794d7609a945f903926ab3d8bd55fe70c8651093578a62c
DIST jaraco.stream-1.1.tar.gz 4887 SHA256 8f1e4aaea35728da594d1430772b85be098a919bf316be721045beb4377526a9 SHA512 5af385084623fbdfe86e9fb620f49b097dee164638bc99622ba557a26cda591e856f1fc4134bc7b73b8f7b61afaf2607686fe20c59c582324a65c22f39d74a13 WHIRLPOOL 5c91d24f8007041cbe76c4ab371776bc1058c714e991eb346ac0c846eda7ead0a532028ed5bc51f8618ee2b7061b5ee6a2e70915c292e4441eb5b5324cfb967f
diff --git a/dev-python/jaraco-stream/jaraco-stream-1.1.1.ebuild b/dev-python/jaraco-stream/jaraco-stream-1.1.1.ebuild
new file mode 100644
index 000000000000..24218e667138
--- /dev/null
+++ b/dev-python/jaraco-stream/jaraco-stream-1.1.1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+MY_PN="${PN/-/.}"
+DESCRIPTION="Routines for handling streaming data"
+HOMEPAGE="https://github.com/jaraco/jaraco.stream"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/more-itertools[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.9[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ >=dev-python/pytest-2.8[${PYTHON_USEDEP}]
+ dev-python/pytest-runner[${PYTHON_USEDEP}]
+ )
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/rst-linker[${PYTHON_USEDEP}]
+ )
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ # Skip one test which requires network access
+ PYTHONPATH=. py.test --ignore=jaraco/stream/test_gzip.py \
+ || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
+ distutils-r1_python_install_all
+}