summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-08-11 00:50:11 +0100
committerSam James <sam@gentoo.org>2021-08-11 00:50:42 +0100
commit82e0c0ea184a60062250520ced7bf6e319a2e609 (patch)
treeba6515579eb7c4a9177040626b1b1f9cf4ce6b8f
parentsci-geosciences/gpsd: add 3.23 (diff)
downloadgentoo-82e0c0ea184a60062250520ced7bf6e319a2e609.tar.gz
gentoo-82e0c0ea184a60062250520ced7bf6e319a2e609.tar.bz2
gentoo-82e0c0ea184a60062250520ced7bf6e319a2e609.zip
sci-geosciences/gpsd: adjust udev rule based on USE=systemd
Closes: https://bugs.gentoo.org/682226 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--sci-geosciences/gpsd/gpsd-3.23.ebuild4
-rw-r--r--sci-geosciences/gpsd/gpsd-9999.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/sci-geosciences/gpsd/gpsd-3.23.ebuild b/sci-geosciences/gpsd/gpsd-3.23.ebuild
index d42188087c84..316786473e7f 100644
--- a/sci-geosciences/gpsd/gpsd-3.23.ebuild
+++ b/sci-geosciences/gpsd/gpsd-3.23.ebuild
@@ -30,7 +30,7 @@ GPSD_PROTOCOLS=(
superstar2 tnt tripmate tsip ublox
)
IUSE_GPSD_PROTOCOLS=${GPSD_PROTOCOLS[@]/#/+gpsd_protocols_}
-IUSE="${IUSE_GPSD_PROTOCOLS} bluetooth +cxx dbus debug ipv6 latency-timing ncurses ntp python qt5 +shm +sockets static test udev usb X"
+IUSE="${IUSE_GPSD_PROTOCOLS} bluetooth +cxx dbus debug ipv6 latency-timing ncurses ntp python qt5 +shm +sockets static systemd test udev usb X"
REQUIRED_USE="X? ( python )
gpsd_protocols_nmea2000? ( gpsd_protocols_aivdm )
gpsd_protocols_isync? ( gpsd_protocols_ublox )
@@ -137,7 +137,7 @@ src_configure() {
gpsd_user=gpsd
gpsd_group=dialout
nostrip=True
- systemd=yes
+ systemd=$(usex systemd)
unitdir="\$prefix/$(get_libdir)"
shared=$(usex !static True False)
bluez=$(usex bluetooth)
diff --git a/sci-geosciences/gpsd/gpsd-9999.ebuild b/sci-geosciences/gpsd/gpsd-9999.ebuild
index d42188087c84..316786473e7f 100644
--- a/sci-geosciences/gpsd/gpsd-9999.ebuild
+++ b/sci-geosciences/gpsd/gpsd-9999.ebuild
@@ -30,7 +30,7 @@ GPSD_PROTOCOLS=(
superstar2 tnt tripmate tsip ublox
)
IUSE_GPSD_PROTOCOLS=${GPSD_PROTOCOLS[@]/#/+gpsd_protocols_}
-IUSE="${IUSE_GPSD_PROTOCOLS} bluetooth +cxx dbus debug ipv6 latency-timing ncurses ntp python qt5 +shm +sockets static test udev usb X"
+IUSE="${IUSE_GPSD_PROTOCOLS} bluetooth +cxx dbus debug ipv6 latency-timing ncurses ntp python qt5 +shm +sockets static systemd test udev usb X"
REQUIRED_USE="X? ( python )
gpsd_protocols_nmea2000? ( gpsd_protocols_aivdm )
gpsd_protocols_isync? ( gpsd_protocols_ublox )
@@ -137,7 +137,7 @@ src_configure() {
gpsd_user=gpsd
gpsd_group=dialout
nostrip=True
- systemd=yes
+ systemd=$(usex systemd)
unitdir="\$prefix/$(get_libdir)"
shared=$(usex !static True False)
bluez=$(usex bluetooth)