summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2020-05-22 15:02:10 +0200
committerAlfredo Tupone <tupone@gentoo.org>2020-05-22 15:02:10 +0200
commit8340b864d6f13481361dcbead5931ab0741ed610 (patch)
tree4ebca93628ff02ce917ed8a19b5f75417f4989f3
parentnet-misc/remmina: don't use intermediate CDEPEND anymore (diff)
downloadgentoo-8340b864d6f13481361dcbead5931ab0741ed610.tar.gz
gentoo-8340b864d6f13481361dcbead5931ab0741ed610.tar.bz2
gentoo-8340b864d6f13481361dcbead5931ab0741ed610.zip
app-text/pdfsandwich: fix dependency and full description
Closes: https://bugs.gentoo.org/611532 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
-rw-r--r--app-text/pdfsandwich/metadata.xml3
-rw-r--r--app-text/pdfsandwich/pdfsandwich-0.1.7.ebuild3
2 files changed, 3 insertions, 3 deletions
diff --git a/app-text/pdfsandwich/metadata.xml b/app-text/pdfsandwich/metadata.xml
index 36a3f024606..fce36805a6f 100644
--- a/app-text/pdfsandwich/metadata.xml
+++ b/app-text/pdfsandwich/metadata.xml
@@ -16,8 +16,7 @@ OCR scanned books or journals. It is able to recognize the page layout
even for multicolumn text.
Essentially, pdfsandwich is a wrapper script which calls the following
-binaries: convert, cuneiform, gs, and hocr2pdf. It is known to run on
-Unix systems and has been tested on Linux and MacOS X. It supports
+binaries: unpaper, convert, gs, and tesseract. It supports
parallel processing on multiprocessor systems.
</longdescription>
<upstream>
diff --git a/app-text/pdfsandwich/pdfsandwich-0.1.7.ebuild b/app-text/pdfsandwich/pdfsandwich-0.1.7.ebuild
index 23eef187cf7..c42e8230671 100644
--- a/app-text/pdfsandwich/pdfsandwich-0.1.7.ebuild
+++ b/app-text/pdfsandwich/pdfsandwich-0.1.7.ebuild
@@ -12,10 +12,11 @@ KEYWORDS="~amd64 ~x86"
SLOT="0"
IUSE="png"
-RDEPEND=">=app-text/tesseract-3.00
+RDEPEND="app-text/tesseract
media-gfx/exact-image
app-text/unpaper
app-text/ghostscript-gpl
+ app-text/poppler
virtual/imagemagick-tools[png?]"
DEPEND="sys-apps/gawk
>=dev-lang/ocaml-3.10[ocamlopt]"