summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZhang Zongyu <zongyu@novazy.net>2022-09-29 20:45:36 +0800
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-09-30 14:09:56 +0200
commit834c70df02cc32759474c76ebb1f069b7ad550fb (patch)
tree9da69ebf07b94d7382b1c487092e3de811dfc63f
parentapp-backup/duplicity: stabilize 0.8.23-r1 for amd64 (diff)
downloadgentoo-834c70df02cc32759474c76ebb1f069b7ad550fb.tar.gz
gentoo-834c70df02cc32759474c76ebb1f069b7ad550fb.tar.bz2
gentoo-834c70df02cc32759474c76ebb1f069b7ad550fb.zip
sci-libs/blis: bump version to 0.9.0
Closes: https://bugs.gentoo.org/693470 Closes: https://bugs.gentoo.org/841440 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Zhang Zongyu <zongyu@novazy.net> Closes: https://github.com/gentoo/gentoo/pull/27534 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
-rw-r--r--sci-libs/blis/Manifest1
-rw-r--r--sci-libs/blis/blis-0.9.0.ebuild113
-rw-r--r--sci-libs/blis/files/blis-0.9.0-rpath.patch15
3 files changed, 129 insertions, 0 deletions
diff --git a/sci-libs/blis/Manifest b/sci-libs/blis/Manifest
index ec8f4283416a..5e90ff7400e3 100644
--- a/sci-libs/blis/Manifest
+++ b/sci-libs/blis/Manifest
@@ -1,2 +1,3 @@
DIST blis-0.6.0.tar.gz 5107257 BLAKE2B cd589ad1216486e8bb0cf574cc096c1e1f2bb9587b182c2bcff44db322468d9f027323c0bf2d22ea0fabb1902dc047d2bf62253ef1c2797fc3de9ba53d7fc34a SHA512 74e9da5146f7986cbd11651d7cd0837562a1603c667b9e6d3f79b5057443de657b60d7463cb2d64daf3eff7d33fc05a64e6d8eb807f4cabe0c3121517924a206
DIST blis-0.8.1.tar.gz 13442609 BLAKE2B cc4167aaa6461b73876f428de2ab02107803fd6d63df101bf30de4c6ca57241e29f09dfb82fe1cfec8c661b2d9efe65ab854ad7719bf36e27f8a33bf3dd4bb92 SHA512 f920e6ae699af899caca27274b55bb944c886c882dfc06bc2f66d069c08e6d4999c130626cd96297308c1b7e85e77e6552bf981cce37dbbaa5acdf0cb5078e02
+DIST blis-0.9.0.tar.gz 15078619 BLAKE2B f7c9632024e0adbba370a4077a7a47f05c54779ad6195b2ccda0950df8e784b8988b4338758ec2fabd424a69009010f8f02cbaef0eda1d74f6794127b43b4f70 SHA512 01e1990eefa4387839ac404089e4ffa32922ceaa30a1747c08a931c67706bcf29fed9d25e30c0faa36bba4f460821290e7973ed6b657d2cd95e126caaf853f81
diff --git a/sci-libs/blis/blis-0.9.0.ebuild b/sci-libs/blis/blis-0.9.0.ebuild
new file mode 100644
index 000000000000..9e2aa275f970
--- /dev/null
+++ b/sci-libs/blis/blis-0.9.0.ebuild
@@ -0,0 +1,113 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+inherit python-any-r1
+
+DESCRIPTION="BLAS-like Library Instantiation Software Framework"
+HOMEPAGE="https://github.com/flame/blis"
+SRC_URI="https://github.com/flame/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="doc eselect-ldso openmp pthread serial static-libs 64bit-index"
+REQUIRED_USE="
+ ?? ( openmp pthread serial )
+ ?? ( eselect-ldso 64bit-index )"
+
+DEPEND="
+ eselect-ldso? (
+ !app-eselect/eselect-cblas
+ >=app-eselect/eselect-blas-0.2
+ )"
+
+RDEPEND="${DEPEND}"
+BDEPEND="${PYTHON_DEPS}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.6.0-blas-provider.patch
+ # to prevent QA Notice: pkg-config files with wrong LDFLAGS detected
+ "${FILESDIR}"/${PN}-0.8.1-pkg-config.patch
+ "${FILESDIR}"/${PN}-0.9.0-rpath.patch
+)
+
+src_configure() {
+ local BLIS_FLAGS=()
+ local confname
+ # determine flags
+ if use openmp; then
+ BLIS_FLAGS+=( -t openmp )
+ elif use pthread; then
+ BLIS_FLAGS+=( -t pthreads )
+ else
+ BLIS_FLAGS+=( -t no )
+ fi
+ use 64bit-index && BLIS_FLAGS+=( -b 64 -i 64 )
+ # determine config name
+ case "${ARCH}" in
+ "x86" | "amd64")
+ confname=auto ;;
+ "ppc64")
+ confname=generic ;;
+ *)
+ confname=generic ;;
+ esac
+ # This is not an autotools configure file. We don't use econf here.
+ ./configure \
+ --enable-verbose-make \
+ --prefix="${BROOT}"/usr \
+ --libdir="${BROOT}"/usr/$(get_libdir) \
+ $(use_enable static-libs static) \
+ --enable-blas \
+ --enable-cblas \
+ "${BLIS_FLAGS[@]}" \
+ --enable-shared \
+ $confname || die
+}
+
+src_compile() {
+ DEB_LIBBLAS=libblas.so.3 DEB_LIBCBLAS=libcblas.so.3 \
+ LDS_BLAS="${FILESDIR}"/blas.lds LDS_CBLAS="${FILESDIR}"/cblas.lds \
+ default
+}
+
+src_test() {
+ LD_LIBRARY_PATH="${S}/lib/haswell" emake check
+}
+
+src_install() {
+ default
+ use doc && dodoc README.md docs/*.md
+
+ if use eselect-ldso; then
+ insinto /usr/$(get_libdir)/blas/blis
+ doins lib/*/lib{c,}blas.so.3
+ dosym libblas.so.3 usr/$(get_libdir)/blas/blis/libblas.so
+ dosym libcblas.so.3 usr/$(get_libdir)/blas/blis/libcblas.so
+ fi
+}
+
+pkg_postinst() {
+ use eselect-ldso || return
+
+ local libdir=$(get_libdir) me="blis"
+
+ # check blas
+ eselect blas add ${libdir} "${EROOT}"/usr/${libdir}/blas/${me} ${me}
+ local current_blas=$(eselect blas show ${libdir} | cut -d' ' -f2)
+ if [[ ${current_blas} == "${me}" || -z ${current_blas} ]]; then
+ eselect blas set ${libdir} ${me}
+ elog "Current eselect: BLAS/CBLAS ($libdir) -> [${current_blas}]."
+ else
+ elog "Current eselect: BLAS/CBLAS ($libdir) -> [${current_blas}]."
+ elog "To use blas [${me}] implementation, you have to issue (as root):"
+ elog "\t eselect blas set ${libdir} ${me}"
+ fi
+}
+
+pkg_postrm() {
+ use eselect-ldso && eselect blas validate
+}
diff --git a/sci-libs/blis/files/blis-0.9.0-rpath.patch b/sci-libs/blis/files/blis-0.9.0-rpath.patch
new file mode 100644
index 000000000000..9687a6c9428b
--- /dev/null
+++ b/sci-libs/blis/files/blis-0.9.0-rpath.patch
@@ -0,0 +1,15 @@
+diff -Nur a/common.mk b/common.mk
+--- a/common.mk 2022-09-29 16:54:14.414899248 +0800
++++ b/common.mk 2022-09-29 16:54:32.915666662 +0800
+@@ -591,9 +591,9 @@
+ LDFLAGS += -Wl,-rpath,@executable_path/../../../$(BASE_LIB_PATH)
+ else
+ # rpath for test_libblis.x
+-LDFLAGS += -Wl,-rpath,'$$ORIGIN/$(BASE_LIB_PATH)'
++#LDFLAGS += -Wl,-rpath,'$$ORIGIN/$(BASE_LIB_PATH)'
+ # rpath for BLAS tests
+-LDFLAGS += -Wl,-rpath,'$$ORIGIN/../../../$(BASE_LIB_PATH)'
++#LDFLAGS += -Wl,-rpath,'$$ORIGIN/../../../$(BASE_LIB_PATH)'
+ endif
+ endif
+ endif