summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-10 17:45:39 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-10 18:47:05 +0200
commit8380c2257e8556b09943d415daf7d0aed5bf0a3e (patch)
tree9b6bd0e925e9c1cc4c92b780efb0c80bcc9baea7
parentdev-python/pydbus: Add pypi remote-id (diff)
downloadgentoo-8380c2257e8556b09943d415daf7d0aed5bf0a3e.tar.gz
gentoo-8380c2257e8556b09943d415daf7d0aed5bf0a3e.tar.bz2
gentoo-8380c2257e8556b09943d415daf7d0aed5bf0a3e.zip
dev-python/pyzotero: Bump to 1.4.23
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pyzotero/Manifest1
-rw-r--r--dev-python/pyzotero/pyzotero-1.4.23.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/pyzotero/Manifest b/dev-python/pyzotero/Manifest
index 7a45509b1593..5632c1ab2a9a 100644
--- a/dev-python/pyzotero/Manifest
+++ b/dev-python/pyzotero/Manifest
@@ -1 +1,2 @@
DIST pyzotero-1.4.22.tar.gz 521386 BLAKE2B 3f5cc943aa108b771675955fcf7acaea62bbed360f7b9a4de4127d086c0c11679090df1e02820c0c937057cb77923c7d48ff95b06d92a6494d2db3b70fa65a27 SHA512 c9438474c30405d54194315ee007ae53527963460621c0e74b8286baa98f324601fbc99d342183ae643919890b70f08cc0ae431836b03e3d9028e62302ec63f8
+DIST pyzotero-1.4.23.tar.gz 521386 BLAKE2B 4d66adc8c66c21c5ec3a21d7c0b2316bb9d983f3e31efdb11cb8840a8f94415b6e7e792d5870a33530fe877215855f7b2bc244fa05987cff0edf48ea850be54c SHA512 383809cf7a5ab950871c47101397e3a073f53d41f723acbcbe91d5c62d56c0618a70433a5ae3332d25195d4bce207c57b7f26b7c4c851621282b994f1afbf4b3
diff --git a/dev-python/pyzotero/pyzotero-1.4.23.ebuild b/dev-python/pyzotero/pyzotero-1.4.23.ebuild
new file mode 100644
index 000000000000..4fd1f87128e5
--- /dev/null
+++ b/dev-python/pyzotero/pyzotero-1.4.23.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python client for the Zotero API"
+HOMEPAGE="https://github.com/urschrei/pyzotero"
+SRC_URI="https://github.com/urschrei/pyzotero/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ app-text/zotero-bin
+ dev-python/bibtexparser[${PYTHON_USEDEP}]
+ <dev-python/feedparser-6[${PYTHON_USEDEP}]
+ dev-python/pathlib2[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+
+BDEPEND="
+ test? (
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/httpretty[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx doc --no-autodoc
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # do not install tests
+ sed -i "s/find_packages(),/find_packages(exclude=('test*')),/g" setup.py || die
+
+ distutils-r1_python_prepare_all
+}