summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPascal Jäger <pascal.jaeger@leimstift.de>2022-10-04 19:36:30 +0200
committerMatt Turner <mattst88@gentoo.org>2022-10-07 18:29:57 -0400
commit83892ec7833ff8ff9ff0e909b7a277475ceaf3bf (patch)
tree521df9e0f3956cc6a62d066463dae25dbf894c4e
parentnet-p2p/transmission: add comment about version.h (diff)
downloadgentoo-83892ec7.tar.gz
gentoo-83892ec7.tar.bz2
gentoo-83892ec7.zip
gnome-base/gnome-panel: fix elogind build
Closes: https://bugs.gentoo.org/787431 Signed-off-by: Pascal Jäger <pascal.jaeger@leimstift.de> Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--gnome-base/gnome-panel/gnome-panel-3.44.0-r2.ebuild (renamed from gnome-base/gnome-panel/gnome-panel-3.44.0-r1.ebuild)6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnome-base/gnome-panel/gnome-panel-3.44.0-r1.ebuild b/gnome-base/gnome-panel/gnome-panel-3.44.0-r2.ebuild
index 248101e116ee..e2782d5ff07f 100644
--- a/gnome-base/gnome-panel/gnome-panel-3.44.0-r1.ebuild
+++ b/gnome-base/gnome-panel/gnome-panel-3.44.0-r2.ebuild
@@ -59,6 +59,8 @@ src_configure() {
# to force a manual recheck. Only update the explicit version if the
# "PKG_CHECK_MODULES([MENU], ...)" block did not change; otherwise adjust
# elogind conditional block below accordingly first.
+ # DO NOT just change the version, look in configure.ac in which PKG_CHECK_MODULES-sections
+ # libsystemd is used and check if there are new sections where it is used!
if ver_test ${PV} -ne 3.44.0; then
die "Maintainer has not checked over packages MENU pkg-config deps for elogind support"
fi
@@ -66,6 +68,10 @@ src_configure() {
if use elogind; then
local pkgconfig="$(tc-getPKG_CONFIG)"
myconf+=(
+ ACTION_BUTTON_CFLAGS="$(${pkgconfig} --cflags gio-unix-2.0 gtk+-3.0 libelogind x11)"
+ ACTION_BUTTON_LIBS="$(${pkgconfig} --libs gio-unix-2.0 gtk+-3.0 libelogind x11)"
+ LAUNCHER_CFLAGS="$(${pkgconfig} --cflags gio-unix-2.0 gtk+-3.0 libgnome-menu-3.0 libelogind)"
+ LAUNCHER_LIBS="$(${pkgconfig} --libs gio-unix-2.0 gtk+-3.0 libgnome-menu-3.0 libelogind)"
MENU_CFLAGS="$(${pkgconfig} --cflags gdm gio-unix-2.0 gtk+-3.0 libgnome-menu-3.0 libelogind)"
MENU_LIBS="$(${pkgconfig} --libs gdm gio-unix-2.0 gtk+-3.0 libgnome-menu-3.0 libelogind)"
)