summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-06-25 20:03:52 -0400
committerTim Harder <radhermit@gentoo.org>2018-06-25 20:04:56 -0400
commit84198d3e87a5e27f43b2fa4642cb4520ae27ee81 (patch)
treef58b90d86ce68ef8c80a76bcd4be6b5d24c3cc6f
parentdev-python/psutil: version bump to 5.4.6 (diff)
downloadgentoo-84198d3e87a5e27f43b2fa4642cb4520ae27ee81.tar.gz
gentoo-84198d3e87a5e27f43b2fa4642cb4520ae27ee81.tar.bz2
gentoo-84198d3e87a5e27f43b2fa4642cb4520ae27ee81.zip
dev-python/werkzeug: version bump to 0.14.1
-rw-r--r--dev-python/werkzeug/Manifest1
-rw-r--r--dev-python/werkzeug/werkzeug-0.14.1.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/werkzeug/Manifest b/dev-python/werkzeug/Manifest
index 02069a143470..5e9a421b2099 100644
--- a/dev-python/werkzeug/Manifest
+++ b/dev-python/werkzeug/Manifest
@@ -1 +1,2 @@
DIST Werkzeug-0.12.2.tar.gz 1169770 BLAKE2B 12e7e422e7dae0ab2fc3cc52f80536362dea8edd61cdaec45a6cca35b789d731408e10cc46288b0c5c22138e20e9d52a88c2db78d22a215d5ab4bb9477526fcc SHA512 9ff45aeb51a71fd5115e8cdee40a7b2fddfa0574c356686050cb1bdced5c6c18f672b601ca2637010c7f59be75c66ee558efb4ea05052c550ec7da3644b88e0a
+DIST Werkzeug-0.14.1.tar.gz 1185546 BLAKE2B 4c358688752adce870e8b44ffede56e44ab26990f12c98cc75a7c7e0d40b1f39f4208237ed26a2acb1f78a3359272cb44bab4606c5bca55a5c5f5edfa22c9faa SHA512 64976cc46c1cee2203112c50aba6f9404d4e48d4a90f8b11837148b5415a28572b7e706095586045a46879e853fc5a80c63e7bf0c13eda29d564a37b4a554c0b
diff --git a/dev-python/werkzeug/werkzeug-0.14.1.ebuild b/dev-python/werkzeug/werkzeug-0.14.1.ebuild
new file mode 100644
index 000000000000..f6f7c586eacf
--- /dev/null
+++ b/dev-python/werkzeug/werkzeug-0.14.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+MY_PN="Werkzeug"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Collection of various utilities for WSGI applications"
+HOMEPAGE="http://werkzeug.pocoo.org/ https://pypi.org/project/Werkzeug/ https://github.com/pallets/werkzeug"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND="dev-python/simplejson[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-xprocess[${PYTHON_USEDEP}]
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+python_test() {
+ py.test -v tests || die "Tests failed under ${EPYTHON}"
+}