summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-10-18 11:41:14 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-10-18 11:44:26 +0300
commit84fc5bfad74bd1fbc9b95251d48007b601fae414 (patch)
tree6de95def8b96b18f2025e71cd0d23ec0762ebe31
parentdev-python/configshell-fb: enable py3.10, py3.9 (diff)
downloadgentoo-84fc5bfad74bd1fbc9b95251d48007b601fae414.tar.gz
gentoo-84fc5bfad74bd1fbc9b95251d48007b601fae414.tar.bz2
gentoo-84fc5bfad74bd1fbc9b95251d48007b601fae414.zip
dev-python/configshell-fb: add 1.1.29
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/configshell-fb/Manifest1
-rw-r--r--dev-python/configshell-fb/configshell-fb-1.1.29.ebuild19
2 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/configshell-fb/Manifest b/dev-python/configshell-fb/Manifest
index 2e0c19b3316d..eec9fe017a14 100644
--- a/dev-python/configshell-fb/Manifest
+++ b/dev-python/configshell-fb/Manifest
@@ -1 +1,2 @@
DIST configshell-fb-1.1.28.tar.gz 55076 BLAKE2B 8f7ab1b6172412dffd77d1ba89082f815b90167b5bc7e15c26c26a101e2e8a0ab5bc716c040f41124a9d5a5038b751e4cd882124d70fe2fda2b796ef43dc97c8 SHA512 7d05fdfca5646ec05d5f4b2ea499235237f5f3157c1330ed46dcc76ce8dea5cca0e3ec4d4376db2ec8358438737fb54286cb0c712c0f16637128670d2858dd4d
+DIST configshell-fb-1.1.29.tar.gz 55036 BLAKE2B 4a9a8f2573b43a9c8ddbda837e831c96b221f4499acb1aeeb990a7b1050c5572e9b745857ac9d1de4089d1758dd1284d0555da524def80e0a1caac18bb43a921 SHA512 0d7663cf58431c8b0be5618e5ef454838489e11a3074e5bd63145c3ea965065e37f1a41b5775363a35498a4d5dd86ad5453feb58dd74853cd77ae196b44c658e
diff --git a/dev-python/configshell-fb/configshell-fb-1.1.29.ebuild b/dev-python/configshell-fb/configshell-fb-1.1.29.ebuild
new file mode 100644
index 000000000000..378a56f89e46
--- /dev/null
+++ b/dev-python/configshell-fb/configshell-fb-1.1.29.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A Python library for building configuration shells"
+HOMEPAGE="https://github.com/open-iscsi/configshell-fb"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]"