summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-10-10 00:21:27 -0400
committerMatt Turner <mattst88@gentoo.org>2022-10-10 00:21:27 -0400
commit85cb0bb9b1d6963dc7b2231f363ac6346d0e519d (patch)
tree5cd65ac320a687c1a29c7aa9a736571bf8ac657c
parentapp-backup/deja-dup: Drop old versions (diff)
downloadgentoo-85cb0bb9b1d6963dc7b2231f363ac6346d0e519d.tar.gz
gentoo-85cb0bb9b1d6963dc7b2231f363ac6346d0e519d.tar.bz2
gentoo-85cb0bb9b1d6963dc7b2231f363ac6346d0e519d.zip
media-video/libva-utils: Version bump to 2.16.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
-rw-r--r--media-video/libva-utils/Manifest1
-rw-r--r--media-video/libva-utils/libva-utils-2.16.0.ebuild91
2 files changed, 92 insertions, 0 deletions
diff --git a/media-video/libva-utils/Manifest b/media-video/libva-utils/Manifest
index e8905bbfec08..893fbad39180 100644
--- a/media-video/libva-utils/Manifest
+++ b/media-video/libva-utils/Manifest
@@ -1,2 +1,3 @@
DIST libva-utils-2.14.0.tar.gz 1241072 BLAKE2B 17f1e0badb05e39f3979bde652dfe6832e8bfb2accd99fd6c5d972090cfce630e2a93ad96e5d17bc7bd9c393b12c2a7b066cb60a715c2dbb128dd263c480bcca SHA512 631e9becf5b2f6d083906962c004c9080d2e2b2d98b6003638a31dde8ad4e2549606301b97e88822471e29007232fc470a2116be09dc0c55d3cc2df6a45a7be1
DIST libva-utils-2.15.0.tar.gz 1245559 BLAKE2B 92fe1e7dbd3c953eecb351625213c2b537ad640f61534f3316d3a46070cb3818b4acafbc7a666e24b51d0900cea044074a7a6519f3c4aba6d2a38cf6ed0b2d66 SHA512 90cfa83fb7443fc90558c148c740c9c272796197fba49ff0179af94c40e97c830fc26c534e9a74fa58f597075f9ba68b477aabc784148c14dc09bde07f23cdeb
+DIST libva-utils-2.16.0.tar.gz 1245723 BLAKE2B 3ce3b54f9b8d1e5960fdb7587da9dc4fa9754f3612155e86d99f2f120e31e0e69a40482d7a4571fefc0a8079ba987303cbb433203de9ef6e203e9419b6d91b91 SHA512 d5395c1de4b95f4d0a86621b0338852250a3893b732c6fd69d0622c989bff530461a183c151f322469b1ed7e4815173dbbcf36cc390db9ebbae6fb7d7a90cb9c
diff --git a/media-video/libva-utils/libva-utils-2.16.0.ebuild b/media-video/libva-utils/libva-utils-2.16.0.ebuild
new file mode 100644
index 000000000000..428cc77cbc2d
--- /dev/null
+++ b/media-video/libva-utils/libva-utils-2.16.0.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Collection of utilities and tests for VA-API"
+HOMEPAGE="https://01.org/linuxmedia/vaapi"
+if [[ ${PV} = *9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/intel/libva-utils"
+else
+ SRC_URI="https://github.com/intel/libva-utils/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="examples putsurface test +vainfo wayland X"
+RESTRICT="test" # Tests must be run manually
+
+REQUIRED_USE="
+ putsurface? ( || ( wayland X ) )
+ || ( examples putsurface test vainfo )
+"
+
+DEPEND="
+ x11-libs/libdrm
+ wayland? ( >=dev-libs/wayland-1.0.6 )
+ X? ( >=x11-libs/libX11-1.6.2 )
+"
+if [[ ${PV} = *9999 ]] ; then
+ DEPEND+="~x11-libs/libva-${PV}:=[drm(+),wayland?,X?]"
+else
+ DEPEND+=">=x11-libs/libva-$(ver_cut 1-2).0:=[drm(+),wayland?,X?]"
+fi
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ local sed_args=()
+
+ if ! use examples ; then
+ sed_args+=(
+ -e "/^subdir('decode')$/d"
+ -e "/^subdir('encode')$/d"
+ -e "/^subdir('videoprocess')$/d"
+ -e "/^subdir('vendor\/intel')$/d"
+ -e "/^subdir('vendor\/intel\/sfcsample')$/d"
+ )
+ fi
+
+ if ! use putsurface ; then
+ sed_args+=(-e "/^subdir('putsurface')$/d")
+ fi
+
+ if ! use vainfo ; then
+ sed_args+=(-e "/^subdir('vainfo')$/d")
+ fi
+
+ if [[ ${#sed_args[@]} -gt 0 ]] ; then
+ sed "${sed_args[@]}" -i meson.build || die
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ -Ddrm=true
+ $(meson_use X x11)
+ $(meson_use wayland)
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+
+ if ! use test ; then
+ rm -f "${ED}"/usr/bin/test_va_api || die
+ fi
+}
+
+pkg_postinst() {
+ if use test ; then
+ elog "Tests must be run manually with the test_va_api binary"
+ fi
+}