summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2018-02-22 13:19:12 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2018-02-22 13:58:56 -0600
commit85fc318456e5321b2535e20d3e12c39fb1430575 (patch)
tree8967a216e7740bc802d650c0982d40eb379479e3
parentdev-python/python-barbicanclient: 4.6.0 bup (diff)
downloadgentoo-85fc318456e5321b2535e20d3e12c39fb1430575.tar.gz
gentoo-85fc318456e5321b2535e20d3e12c39fb1430575.tar.bz2
gentoo-85fc318456e5321b2535e20d3e12c39fb1430575.zip
dev-python/psutil: 5.4.3 bup
Package-Manager: Portage-2.3.19, Repoman-2.3.6
-rw-r--r--dev-python/psutil/Manifest1
-rw-r--r--dev-python/psutil/psutil-5.4.3.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/psutil/Manifest b/dev-python/psutil/Manifest
index 0e84cd13a7ba..7bab1c3d842b 100644
--- a/dev-python/psutil/Manifest
+++ b/dev-python/psutil/Manifest
@@ -1 +1,2 @@
DIST psutil-5.4.1.tar.gz 408489 BLAKE2B 867dd9b535134ff2ef5960f774891eb4743afc5857c4e0ba7306bd4feb42f3b255a6174a092eff2814f3e2ec9d29179d23ffe495ca85dba56fc42616e67c9a8b SHA512 84d9f61cc6c51798d98ac2f727a50d85de32171645d01abf85d4f8c58bdb3b40997ab717f859de3ea21cf5b24867e1a416ee3036d6167d3fe735eca4607a110f
+DIST psutil-5.4.3.tar.gz 412550 BLAKE2B c12a8418e7a7573d23a2599c6a4df9a3aa3bbe6b9cbef9e0f48b0379944e2aa06ed498adfddc30e8d9ba8e02a08f79d4867dc1e313a62040ad3550d69d62664f SHA512 f2a0f3089c3436df52d509576795e1de14c4127918fbe63b8f116f7c097ba4d67e3b55a8da167a88c6ffd340bb443109d4887c03371810997ced4478b295f960
diff --git a/dev-python/psutil/psutil-5.4.3.ebuild b/dev-python/psutil/psutil-5.4.3.ebuild
new file mode 100644
index 000000000000..0f47dc7a64cd
--- /dev/null
+++ b/dev-python/psutil/psutil-5.4.3.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Retrieve information on running processes and system utilization"
+HOMEPAGE="https://github.com/giampaolo/psutil https://pypi.python.org/pypi/psutil/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="test"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )
+"
+
+RESTRICT="test"
+
+python_test() {
+ ${PYTHON} psutil/tests/runner.py || die
+}