summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStefan Strogin <steils@gentoo.org>2020-06-09 01:59:47 +0300
committerStefan Strogin <steils@gentoo.org>2020-06-09 02:03:40 +0300
commit8620817027b36a4a70349dc516c5b658e160a262 (patch)
treef0c36a52576ca7ac29fa19c1513856e5d6db427f
parentprofiles: mask sys-libs/pam-1.4.0 for testing (diff)
downloadgentoo-8620817027b36a4a70349dc516c5b658e160a262.tar.gz
gentoo-8620817027b36a4a70349dc516c5b658e160a262.tar.bz2
gentoo-8620817027b36a4a70349dc516c5b658e160a262.zip
games-misc/openmsx: fix Python 3 patch; add python3_8
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Stefan Strogin <steils@gentoo.org>
-rw-r--r--games-misc/openmsx/files/openmsx-0.3.1-python3.patch8
-rw-r--r--games-misc/openmsx/openmsx-0.3.1-r4.ebuild (renamed from games-misc/openmsx/openmsx-0.3.1-r3.ebuild)2
2 files changed, 5 insertions, 5 deletions
diff --git a/games-misc/openmsx/files/openmsx-0.3.1-python3.patch b/games-misc/openmsx/files/openmsx-0.3.1-python3.patch
index 0e8a44a5ec3d..df403e27a22a 100644
--- a/games-misc/openmsx/files/openmsx-0.3.1-python3.patch
+++ b/games-misc/openmsx/files/openmsx-0.3.1-python3.patch
@@ -1,4 +1,4 @@
-From 7b298b1bacc56392b9a19ba6b95d368309832ad7 Mon Sep 17 00:00:00 2001
+From 5857a22e79dc77c9b571297451dc11c4a68bc198 Mon Sep 17 00:00:00 2001
From: Stefan Strogin <steils@gentoo.org>
Date: Fri, 7 Feb 2020 13:15:16 +0200
Subject: [PATCH] Fix: support Python 3
@@ -47,7 +47,7 @@ index 689ddb9..e041d64 100755
+ sys.stdout.flush()
+ break
diff --git a/scripts/md5list.py b/scripts/md5list.py
-index cf611fc..a60f977 100755
+index cf611fc..781052e 100755
--- a/scripts/md5list.py
+++ b/scripts/md5list.py
@@ -16,28 +16,28 @@ import subprocess
@@ -89,7 +89,7 @@ index cf611fc..a60f977 100755
+ md5call = md5call + ["src/"+separate[1].strip()]
+ md5sum = subprocess.Popen(md5call, stdout=subprocess.PIPE).communicate()[0]
+ md5sum = md5sum.split()
-+ res = "%-32s = %s\n" % (separate[1], md5sum[0])
++ res = "%-32s = %s\n" % (separate[1], md5sum[0].decode())
+ sys.stdout.write(res)
else:
- md5call = ["md5sum"]
@@ -302,5 +302,5 @@ index f97709a..5368831 100755
\ No newline at end of file
+ print(str.strip())
--
-2.25.0
+2.27.0
diff --git a/games-misc/openmsx/openmsx-0.3.1-r3.ebuild b/games-misc/openmsx/openmsx-0.3.1-r4.ebuild
index 256776545d93..9edc7a8b3e3d 100644
--- a/games-misc/openmsx/openmsx-0.3.1-r3.ebuild
+++ b/games-misc/openmsx/openmsx-0.3.1-r4.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6,7,8} )
inherit python-any-r1