summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James (sam_c) <sam@cmpct.info>2020-05-14 12:52:33 +0000
committerIan Whyman <thev00d00@gentoo.org>2020-05-23 10:56:19 +0100
commit8628d24d6e1cf9078c5c89698b8ec926995bad8d (patch)
tree574e9c76f01befc99adf9e933650887cad579c28
parentdev-python/kivy-garden: Remove last-rited pkg (diff)
downloadgentoo-8628d24d6e1cf9078c5c89698b8ec926995bad8d.tar.gz
gentoo-8628d24d6e1cf9078c5c89698b8ec926995bad8d.tar.bz2
gentoo-8628d24d6e1cf9078c5c89698b8ec926995bad8d.zip
dev-python/rarfile: Bump to EAPI=7
* EAPI 7 * Adds Python 3.7, 3.8, PyPy 3 * Enables tests Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Sam James (sam_c) <sam@cmpct.info> Closes: https://github.com/gentoo/gentoo/pull/15794 Closes: https://bugs.gentoo.org/719520 Signed-off-by: Ian Whyman <thev00d00@gentoo.org>
-rw-r--r--dev-python/rarfile/rarfile-3.0-r1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/rarfile/rarfile-3.0-r1.ebuild b/dev-python/rarfile/rarfile-3.0-r1.ebuild
new file mode 100644
index 000000000000..3b2be61a9fb4
--- /dev/null
+++ b/dev-python/rarfile/rarfile-3.0-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Module for RAR archive reading"
+HOMEPAGE="https://github.com/markokr/rarfile"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+compressed"
+
+RDEPEND="compressed? ( || ( app-arch/unrar app-arch/rar ) )"
+
+distutils_enable_tests nose