summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2022-02-17 22:23:19 +0900
committerAkinori Hattori <hattya@gentoo.org>2022-02-17 22:27:23 +0900
commit86889c94e7d17e086991710541a1749c68995d0d (patch)
tree678f09876adfbfcaa2b6a528b93cd92ca8a38dc8
parentsci-mathematics/coq: enable doc (diff)
downloadgentoo-86889c94e7d17e086991710541a1749c68995d0d.tar.gz
gentoo-86889c94e7d17e086991710541a1749c68995d0d.tar.bz2
gentoo-86889c94e7d17e086991710541a1749c68995d0d.zip
app-i18n/ibus-typing-booster: new upstream release
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Akinori Hattori <hattya@gentoo.org>
-rw-r--r--app-i18n/ibus-typing-booster/Manifest1
-rw-r--r--app-i18n/ibus-typing-booster/ibus-typing-booster-2.15.16.ebuild54
2 files changed, 55 insertions, 0 deletions
diff --git a/app-i18n/ibus-typing-booster/Manifest b/app-i18n/ibus-typing-booster/Manifest
index 0775af7da6e6..c39448c87f43 100644
--- a/app-i18n/ibus-typing-booster/Manifest
+++ b/app-i18n/ibus-typing-booster/Manifest
@@ -1,2 +1,3 @@
DIST ibus-typing-booster-2.14.13.tar.gz 10239396 BLAKE2B 1c4db896f28f3f1b58bd3071fb6f2d5c1b2b4e0fbad43568ae25d69f301d4ce408ca6c2fb829818f6981c2f212c499c1dfabc3511f09f7a9f5c3d4ae2d08a212 SHA512 4e1f1c39fea030f1f056966007127afeb5c6c098a66ecd6fe0b4ea60f302438e072d6d409ef2bee9ea5b0d1048b5a22d7e4fad9f7f509362e2af251855f6e535
DIST ibus-typing-booster-2.15.11.tar.gz 10250973 BLAKE2B 1285d34535fc7087d19c1e01f70ace3aacc4a45ae04d7ab32c2af7b61eab7b547fa901ee01ddd1b1356de7fcb1f30d8c0dce58692b8b9448442eb5bdcdd9f7bd SHA512 38e74e6b95bff13f7b166158c145aa9d2180ba70380dad428fce322535b959cd3b8980ed499c2aec4a9701f1398b4ce793b99ce0af30c1eb2ce015bd35b990a7
+DIST ibus-typing-booster-2.15.16.tar.gz 10279700 BLAKE2B 75f9ea696ec5320e56ce06926c7fec56ea5918e90ac2abe416a6161e358564c2851588487672b711a28a6a770372300a90b3717fe3a8d51b118a937136cff7e5 SHA512 5a2f315f3def693508f25dbc0fbda8b7a8d6b260e9a676cd38b720e059e3600a6abebc8f06581fe6e96e7f825eb3401235ebfa5a5ff491b39d5804469b2d2fa0
diff --git a/app-i18n/ibus-typing-booster/ibus-typing-booster-2.15.16.ebuild b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.15.16.ebuild
new file mode 100644
index 000000000000..58166b805e3c
--- /dev/null
+++ b/app-i18n/ibus-typing-booster/ibus-typing-booster-2.15.16.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit gnome2-utils python-single-r1 xdg
+
+DESCRIPTION="Completion input method for IBus"
+HOMEPAGE="https://mike-fabian.github.io/ibus-typing-booster"
+SRC_URI="https://github.com/mike-fabian/${PN}/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ dev-libs/m17n-lib
+ $(python_gen_cond_dep '
+ app-i18n/ibus[python(+),${PYTHON_USEDEP}]
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pyenchant[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ ')"
+RDEPEND="${DEPEND}
+ >=dev-db/m17n-db-1.7"
+BDEPEND="sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ sed -i "s|/usr\(/bin/sh\)|\1|" {engine,setup}/*.in
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}