summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-04-18 16:01:10 +0200
committerMichał Górny <mgorny@gentoo.org>2019-04-18 16:01:10 +0200
commit86c99d6837b46807577c940c66ce4ed99ba341ae (patch)
tree6780b2332d0362b070c5cca54bd00ef548d3143c
parentpackage.mask: Last rite dev-cpp/gccxml and revdeps (diff)
downloadgentoo-86c99d6837b46807577c940c66ce4ed99ba341ae.tar.gz
gentoo-86c99d6837b46807577c940c66ce4ed99ba341ae.tar.bz2
gentoo-86c99d6837b46807577c940c66ce4ed99ba341ae.zip
dev-libs/quantlib: Drop old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-libs/quantlib/Manifest1
-rw-r--r--dev-libs/quantlib/quantlib-1.6.ebuild97
2 files changed, 0 insertions, 98 deletions
diff --git a/dev-libs/quantlib/Manifest b/dev-libs/quantlib/Manifest
index ebd1215d8db8..306c2ca499a8 100644
--- a/dev-libs/quantlib/Manifest
+++ b/dev-libs/quantlib/Manifest
@@ -1,2 +1 @@
-DIST QuantLib-1.6.tar.gz 8714267 BLAKE2B f59b1250ea653d6b999945a3f19632fb071656eb6f7f90c6483db2f0f2104169ab0c8155c1205b16c002a78da73ff7a7b25f948a0adeca679e9e5cf127e09212 SHA512 c38cc894873a36942c022c1d70eb7b0c5f2e9208ee9e949a656aef02fb9fe95436955b560b61188ea5a374f4b7674b46629178779e066135396f291788d772c4
DIST QuantLib-1.7.1.tar.gz 8715844 BLAKE2B 0193f1b6d73d66b148840671b7321e926a81a3eec2d1ded3a3398e9531c71cdb12454e059960b7707c9383bedddd136ab92e2550bdda265c54b0cf26d904b972 SHA512 8ba4fdb219b2886b448dbc6370ce6acec9f919a6baf7e8275a76ba13e0bf2d08cbb88cd5a3e450bcf379c17bd0492a9259483089de65e24b95d708f259bc30a7
diff --git a/dev-libs/quantlib/quantlib-1.6.ebuild b/dev-libs/quantlib/quantlib-1.6.ebuild
deleted file mode 100644
index 193731dc5a99..000000000000
--- a/dev-libs/quantlib/quantlib-1.6.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit elisp-common eutils toolchain-funcs
-
-MY_P="QuantLib-${PV}"
-
-DESCRIPTION="A comprehensive software framework for quantitative finance"
-HOMEPAGE="https://quantlib.org/"
-SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="debug doc emacs examples openmp static-libs"
-
-RDEPEND="dev-libs/boost:="
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen[dot] )
- emacs? ( virtual/emacs )"
-
-DOCS="*.txt"
-
-S="${WORKDIR}/${MY_P}"
-
-SITEFILE="50${PN}-gentoo.el"
-
-pkg_setup() {
- if use openmp ; then
- tc-has-openmp || die "Please switch to an openmp compatible compiler"
- fi
-}
-
-src_prepare() {
- epatch_user
-}
-
-src_configure() {
- # NOTE: Too fragile for single .pdf or .ps document
- local prog
- for prog in DVIPS LATEX MAKEINDEX PDFLATEX; do
- export ac_cv_path_${prog}=no
- done
-
- use doc || export ac_cv_path_DOXYGEN=no
- use emacs || export ac_cv_prog_EMACS=no
-
- # NOTE: --enable-examples will only change noinst_PROGRAMS to bin_PROGRAMS
- econf \
- $(use_enable debug error-functions) \
- $(use_enable debug error-lines) \
- $(use_enable debug tracing) \
- $(use_enable openmp) \
- $(use_enable static-libs static) \
- --enable-examples \
- --with-lispdir="${SITELISP}/${PN}"
-}
-
-src_compile() {
- default
-
- if use doc; then
- pushd Docs >/dev/null
- emake docs-html
- popd >/dev/null
- fi
-}
-
-src_install(){
- default
- prune_libtool_files
-
- if use doc; then
- find Docs \( -name '.time-stamp*' -o -name '*.doxy' -o -name 'Makefile*' \) -delete || die
- insinto "/usr/share/doc/${PF}"
- doins -r Docs
- fi
-
- if use examples; then
- find Examples -name '.libs' -exec rm -rf {} + || die
- find Examples \( -name '*vc*proj*' -o -name '*.dev' -o -name 'Makefile*' -o -name '*.o' \) -delete || die
- insinto "/usr/share/doc/${PF}"
- doins -r Examples
- fi
-
- use emacs && elisp-site-file-install "${FILESDIR}/${SITEFILE}"
-}
-
-pkg_postinst() {
- use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
-}