summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-11 00:33:46 +0000
committerSam James <sam@gentoo.org>2023-02-11 00:36:14 +0000
commit8823444463e36a03af90ce76eed7e75a91672b3d (patch)
tree1747847e7a2242a37edaaa9b8e3452f7f3a4a1ee
parentx11-misc/i3status: fix filecaps desc. typo (diff)
downloadgentoo-8823444463e36a03af90ce76eed7e75a91672b3d.tar.gz
gentoo-8823444463e36a03af90ce76eed7e75a91672b3d.tar.bz2
gentoo-8823444463e36a03af90ce76eed7e75a91672b3d.zip
x11-misc/i3status: skip tests which needs alsa
Closes: https://bugs.gentoo.org/840622 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--x11-misc/i3status/i3status-2.14.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/x11-misc/i3status/i3status-2.14.ebuild b/x11-misc/i3status/i3status-2.14.ebuild
index 9a1390b6ee6a..4a7d1e2f875a 100644
--- a/x11-misc/i3status/i3status-2.14.ebuild
+++ b/x11-misc/i3status/i3status-2.14.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -29,8 +29,18 @@ DEPEND="
"
PATCHES=(
+
)
+src_prepare() {
+ default
+
+ # Needs an ALSA master device, bug #840622
+ # Also skipped in CI:
+ # https://github.com/i3/i3status/blob/07ad5aef2deea1f10eb6c544593e7a87205f24f8/.github/workflows/main.yml#L34
+ rm -rf testcases/020-percentliteral-volume || die
+}
+
src_configure() {
local emesonargs=(
$(meson_use pulseaudio pulseaudio)