summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoerg Bornkessel <hd_brummy@gentoo.org>2019-12-11 22:52:15 +0100
committerJoerg Bornkessel <hd_brummy@gentoo.org>2019-12-11 23:16:20 +0100
commit887c293a8641586108434d1ba9b8d0313cc8ca04 (patch)
tree66d55b341325a7ade75661b2e8d808fd289731ec
parentmedia-plugins/vdr-extb: fixed mirror://vdrfiles is dead (diff)
downloadgentoo-887c293a8641586108434d1ba9b8d0313cc8ca04.tar.gz
gentoo-887c293a8641586108434d1ba9b8d0313cc8ca04.tar.bz2
gentoo-887c293a8641586108434d1ba9b8d0313cc8ca04.zip
media-plugins/vdr-freecell: fixed dead mirror://vdrfiles
eapi=7 added new src_uri to fix dead mirror Bug: https://bugs.gentoo.org/695898 Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Joerg Bornkessel <hd_brummy@gentoo.org>
-rw-r--r--media-plugins/vdr-freecell/vdr-freecell-0.0.2-r3.ebuild7
-rw-r--r--media-plugins/vdr-freecell/vdr-freecell-0.0.2-r4.ebuild35
2 files changed, 38 insertions, 4 deletions
diff --git a/media-plugins/vdr-freecell/vdr-freecell-0.0.2-r3.ebuild b/media-plugins/vdr-freecell/vdr-freecell-0.0.2-r3.ebuild
index 342e259aa110..368c71bbddcb 100644
--- a/media-plugins/vdr-freecell/vdr-freecell-0.0.2-r3.ebuild
+++ b/media-plugins/vdr-freecell/vdr-freecell-0.0.2-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=5
@@ -6,9 +6,8 @@ EAPI=5
inherit vdr-plugin-2
DESCRIPTION="VDR plugin: play 'Freecell' on the On Screen Display"
-HOMEPAGE="http://www.magoa.net/linux/index.php?view=freecell"
-SRC_URI="http://www.magoa.net/linux/files/${P}.tgz
- mirror://vdrfiles/${PN}/${P}.tgz"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="http://vdr.websitec.de/download/${PN}/${P}.tgz"
SLOT="0"
LICENSE="GPL-2"
diff --git a/media-plugins/vdr-freecell/vdr-freecell-0.0.2-r4.ebuild b/media-plugins/vdr-freecell/vdr-freecell-0.0.2-r4.ebuild
new file mode 100644
index 000000000000..3d10e2af527e
--- /dev/null
+++ b/media-plugins/vdr-freecell/vdr-freecell-0.0.2-r4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vdr-plugin-2
+
+DESCRIPTION="VDR plugin: play 'Freecell' on the On Screen Display"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+SRC_URI="http://vdr.websitec.de/download/${PN}/${P}.tgz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="media-video/vdr"
+
+src_prepare() {
+ vdr-plugin-2_src_prepare
+
+ sed -e "s:RegisterI18n://RegisterI18n:" -i freecell.c
+
+ eapply -p2 "${FILESDIR}/gcc-3.4.patch"
+ eapply "${FILESDIR}/${P}-gentoo.diff"
+ eapply "${FILESDIR}/${P}_vdr-1.5.4-compile.diff"
+}
+
+src_install() {
+ vdr-plugin-2_src_install
+
+ insopts -m0644 -ovdr -gvdr
+ insinto /usr/share/vdr/freecell
+ doins "${S}/${VDRPLUGIN}"/*
+}