summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobert Siebeck <gentoo.2019@r123.de>2021-10-01 18:17:24 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-10-16 10:51:15 +0300
commit88f2907774e1ce85cb28818bc3ba1fc3a0e3fabf (patch)
treeff6bbc9de0a4f6da3aede096370cb6f35accdd94
parentdev-util/cucumber: add 7.1.0 (diff)
downloadgentoo-88f2907774e1ce85cb28818bc3ba1fc3a0e3fabf.tar.gz
gentoo-88f2907774e1ce85cb28818bc3ba1fc3a0e3fabf.tar.bz2
gentoo-88f2907774e1ce85cb28818bc3ba1fc3a0e3fabf.zip
mail-client/alpine: add new version 2.25
Signed-off-by: Robert Siebeck <gentoo.2019@r123.de> Closes: https://github.com/gentoo/gentoo/pull/22461 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
-rw-r--r--mail-client/alpine/Manifest3
-rw-r--r--mail-client/alpine/alpine-2.25.ebuild89
2 files changed, 92 insertions, 0 deletions
diff --git a/mail-client/alpine/Manifest b/mail-client/alpine/Manifest
index 2a78cc93f8e0..5191d81bc8a0 100644
--- a/mail-client/alpine/Manifest
+++ b/mail-client/alpine/Manifest
@@ -1,2 +1,5 @@
DIST alpine-2.24-chappa.patch.gz 172010 BLAKE2B 39f5336ead355a4b78bcdd5b44dc398888bf93f3c3efa95b3ad8a86f3a0dda13f03164a03fbed898150864130648a204a6b5d9e32c3437138878516d014c8bbe SHA512 7152a8e4a79a530345448267204a96bc2585b4fccb23f011fd4dc97bc713696b8eb7ca9563655d8da33570ef14bf29577f82fe0f104c80590a43b0e74ec89e81
DIST alpine-2.24.tar.xz 7341676 BLAKE2B 63e2d9387f1a369f9a4623625524f25eec64c600672092608256fd2827c094fae1384b35da84ec5f5865295744982ede533551dc47b6f0c80f2405ed16cad546 SHA512 642a51f73732ebdf7c40e2b66370aa2f48fb13b349b477871b26295c3e8b860a0cc78dec9f80efc6ea74c548a080ceff04181eb18c35a9c8cae8d8ef831178c5
+DIST alpine-2.25-chappa.patch.gz 172752 BLAKE2B 7d79b4a3bc836061ba0b36b2c51b15662a3c1700b8794ec8c2c2abf0244b1ac75914bef8f14959b1ace14a788432a4b2ae151f9ba6f2920b7840908c5c1421ea SHA512 53484540263ad13e59d29ef93c0e58fc2db52059e1a102e217c28e2da64f993e0523691c02bd4259273af8cee0754ff7629eba24913ee74d6d6b3a2ec4cdae9a
+DIST alpine-2.25-ssl.patch 5431 BLAKE2B 0cf2fcb682fbee41aa988ff089c16b75ebd9bee321c1c130d0b5136e5ca521bded7e9a97cd3ade1c86b17e72136264d4405cc36427a347c9bee84ee8a64548d4 SHA512 698d2a3c3b7b588fe3fcfe0291f0aab05c42b5ea80de1f210c1985082651329b80447de4e8057bc7e962fe8ed5175ea8132bad413c02fb1f0cc67c84e9420642
+DIST alpine-2.25.tar.xz 7495372 BLAKE2B ce2587a309c87ba527d51c360ee0d9627453cce6585631f569eb26db04aa6c5cddb7c9599478092447a040c43e9234e78a942fef4b1186d07c608163f96236be SHA512 76c214cf66f4ac7af3de40357ad3a592ff2a119e327e5f6c256125b7865d46b09197435fe6ac8077ab7a498e4821925939f3f902431ca77baa786e149466a193
diff --git a/mail-client/alpine/alpine-2.25.ebuild b/mail-client/alpine/alpine-2.25.ebuild
new file mode 100644
index 000000000000..7d853c64fc2a
--- /dev/null
+++ b/mail-client/alpine/alpine-2.25.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools toolchain-funcs
+
+DESCRIPTION="An easy to use text-based based mail and news client"
+HOMEPAGE="http://alpine.x10host.com/alpine/ https://repo.or.cz/alpine.git/"
+CHAPPA_PATCH_NAME="${P}-chappa.patch"
+SRC_URI="http://alpine.x10host.com/alpine/release/src/${P}.tar.xz
+ https://repo.or.cz/alpine.git/patch/fb2217ac67706e4cbef69bea41041e2fb8b910e9 -> ${P}-ssl.patch
+ chappa? ( http://alpine.x10host.com/alpine/patches/${P}/all.patch.gz -> ${CHAPPA_PATCH_NAME}.gz ) "
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+chappa ipv6 kerberos ldap nls onlyalpine passfile smime spell ssl threads"
+
+# alpine-2.25-ssl.patch can only be applied when not using the chappa patches.
+REQUIRED_USE="chappa? ( ssl )"
+
+DEPEND="sys-libs/ncurses:=
+ virtual/libcrypt:=
+ kerberos? ( app-crypt/mit-krb5 )
+ ldap? ( net-nds/openldap )
+ spell? ( app-text/aspell )
+ ssl? ( dev-libs/openssl:0= )
+"
+RDEPEND="${DEPEND}
+ app-misc/mime-types
+"
+
+src_prepare() {
+ default
+ if use !ssl; then
+ eapply "${DISTDIR}/${P}-ssl.patch"
+ fi
+ use chappa && eapply "${WORKDIR}/${CHAPPA_PATCH_NAME}"
+ eautoreconf
+ tc-export CC RANLIB AR
+ export CC_FOR_BUILD=$(tc-getBUILD_CC)
+}
+
+src_configure() {
+ myconf=(
+ --without-tcl
+ --with-system-pinerc="${EPREFIX}"/etc/pine.conf
+ --with-system-fixed-pinerc="${EPREFIX}"/etc/pine.conf.fixed
+ $(use_with ldap)
+ $(use_with ssl)
+ $(use_with passfile passfile .pinepwd)
+ $(use_with kerberos krb5)
+ $(use_with threads pthread)
+ $(use_with spell interactive-spellcheck /usr/bin/aspell)
+ $(use_enable nls)
+ $(use_with ipv6)
+ $(use_with smime)
+ )
+
+ if use ssl; then
+ myconf+=(
+ --with-ssl-include-dir="${EPREFIX}"/usr/include/openssl
+ --with-ssl-lib-dir="${EPREFIX}"/usr/$(get_libdir)
+ --with-ssl-certs-dir="${EPREFIX}"/etc/ssl/certs
+ )
+ fi
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ emake -j1 AR=$(tc-getAR)
+}
+
+src_install() {
+ if use onlyalpine ; then
+ dobin alpine/alpine
+ doman doc/man1/alpine.1
+ else
+ emake -j1 DESTDIR="${D}" install
+ doman doc/man1/*.1
+ fi
+ dodoc NOTICE README*
+ dodoc doc/brochure.txt
+ dodoc -r doc/tech-notes/
+ newdoc "${S}/doc/mailcap.unx" mailcap.unx.sample
+ newdoc "${S}/doc/mime.types" mime.types.sample
+ docompress -x /usr/share/doc/${PF}/mailcap.unx.sample /usr/share/doc/${PF}/mime.types.sample
+}