summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-02-16 08:42:49 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-02-16 10:21:57 +0000
commit896734932196bba2465ca6fb0a73d521de884b38 (patch)
treeaf6349838ce44c5d100b872c37f008bf29de3b36
parentdev-haskell/quickcheck: bump up to 2.9.2 (diff)
downloadgentoo-896734932196bba2465ca6fb0a73d521de884b38.tar.gz
gentoo-896734932196bba2465ca6fb0a73d521de884b38.tar.bz2
gentoo-896734932196bba2465ca6fb0a73d521de884b38.zip
dev-haskell/http-api-data: new package, a depend of dev-haskell/persistent-2.6
Converting to/from HTTP API data like URL pieces, headers and query parameters Package-Manager: Portage-2.3.3, Repoman-2.3.1
-rw-r--r--dev-haskell/http-api-data/Manifest1
-rw-r--r--dev-haskell/http-api-data/http-api-data-0.3.3.ebuild43
-rw-r--r--dev-haskell/http-api-data/metadata.xml11
3 files changed, 55 insertions, 0 deletions
diff --git a/dev-haskell/http-api-data/Manifest b/dev-haskell/http-api-data/Manifest
new file mode 100644
index 000000000000..6e6c486ff56e
--- /dev/null
+++ b/dev-haskell/http-api-data/Manifest
@@ -0,0 +1 @@
+DIST http-api-data-0.3.3.tar.gz 17668 SHA256 cb3d7ef8a924a6b03481b7c5e26a580df72cbf89f2e8247e825f43f4b3ba8449 SHA512 125240fe0da41ff118937864cc5386d50b58cba98fa9d463202ac73a07b2d530563c3a7c41f81be42f25d99bcfc12ed01dca095a000f0cefc655d8046c3aa00c WHIRLPOOL 63be4395f094cec89457deca263a730097948fb3bff7fc8a4b77f7014053439a0ae64470405df92ce1aa12c67c37bafd059ccf0e73d617589c11e8093db1fd85
diff --git a/dev-haskell/http-api-data/http-api-data-0.3.3.ebuild b/dev-haskell/http-api-data/http-api-data-0.3.3.ebuild
new file mode 100644
index 000000000000..5ffeca195c30
--- /dev/null
+++ b/dev-haskell/http-api-data/http-api-data-0.3.3.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="Converting to/from HTTP API data like URL pieces, headers and query parameters"
+HOMEPAGE="https://github.com/fizruk/http-api-data"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="use-text-show"
+
+RDEPEND="dev-haskell/hashable:=[profile?]
+ >=dev-haskell/text-0.5:=[profile?]
+ >=dev-haskell/time-locale-compat-0.1.1.0:=[profile?] <dev-haskell/time-locale-compat-0.2:=[profile?]
+ dev-haskell/unordered-containers:=[profile?]
+ dev-haskell/uri-bytestring:=[profile?]
+ >=dev-haskell/uuid-types-1.0.2:=[profile?] <dev-haskell/uuid-types-1.1:=[profile?]
+ >=dev-lang/ghc-7.6.1:=
+ use-text-show? ( >=dev-haskell/text-show-2:=[profile?] )
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.16.0
+ test? ( >=dev-haskell/doctest-0.11 <dev-haskell/doctest-0.12
+ >=dev-haskell/hspec-1.3
+ dev-haskell/hunit
+ >=dev-haskell/quickcheck-2.9
+ >=dev-haskell/quickcheck-instances-0.3.12
+ dev-haskell/uuid )
+"
+
+src_configure() {
+ haskell-cabal_src_configure \
+ $(cabal_flag use-text-show use-text-show)
+}
diff --git a/dev-haskell/http-api-data/metadata.xml b/dev-haskell/http-api-data/metadata.xml
new file mode 100644
index 000000000000..c81c43407198
--- /dev/null
+++ b/dev-haskell/http-api-data/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>haskell@gentoo.org</email>
+ <name>Gentoo Haskell</name>
+ </maintainer>
+ <use>
+ <flag name="use-text-show">Use text-show library for efficient ToHttpApiData implementations</flag>
+ </use>
+</pkgmetadata>