summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-28 22:25:13 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-28 23:01:59 +0100
commit897f5d2ef7831cf2e22041dc8ddd16be1de28016 (patch)
tree4d2f71690d925643a7259da535b29e338aa72826
parentdev-python/keyring: Bump to 23.4.0 (diff)
downloadgentoo-897f5d2ef7831cf2e22041dc8ddd16be1de28016.tar.gz
gentoo-897f5d2ef7831cf2e22041dc8ddd16be1de28016.tar.bz2
gentoo-897f5d2ef7831cf2e22041dc8ddd16be1de28016.zip
dev-python/rich: Bump to 10.15.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/rich/Manifest1
-rw-r--r--dev-python/rich/rich-10.15.0.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/rich/Manifest b/dev-python/rich/Manifest
index 64cde226e5f5..1cbe7c6cf932 100644
--- a/dev-python/rich/Manifest
+++ b/dev-python/rich/Manifest
@@ -1,3 +1,4 @@
DIST rich-10.12.0.tar.gz 16265099 BLAKE2B c2249be5a5008e3e9fd5c301b10d7bc544e4805d4762e87481aa31716e38eb3cb2b81ce80f201fc0d3961574136f47b7b374d6bc7d18e4f55f1f757a7e17e5a2 SHA512 bb42ff24c9eeeae548a6e222ecc03f8b46d763c4b022964bd8fb11517f1a23a7aaa82a2155d5cd3d29cdd1af5fab6cc4f26840a84ce5e26dd740f8706961ce1f
DIST rich-10.13.0.tar.gz 16277448 BLAKE2B e33bca376e1a5b82d0648c7bdda9ce30930b7c095cd8272b573f52dcb056a21be35fb0ef83c939e7feeb458eb4efb7767bf98706a4c58fc134627a0b0f3aa68d SHA512 23ea811fbaa8002416530975fe79c62b42d3c79806d312c172351f632864356be77063d5dc0fe0243d78479fb31a87433a432b115f5cf570f7c6e44c6f773ff0
DIST rich-10.14.0.tar.gz 16276866 BLAKE2B bc7d9a493dd4d283b0890bf385ac219c60cfb80addc226b39418ff26ca598a96c71e56ce7bea34b0508728d5535ed8ef71b21b907c13bb2ac3a1c79afefeb8f2 SHA512 be5f36ca19e4c353b94030f65abd7177f8a8194a2b6d46554c29aaa3e57fca585892634e2b096f407e6ae4ae47a7f9844fb7686c34e10d4bbccb0ea35a7d2247
+DIST rich-10.15.0.tar.gz 16279650 BLAKE2B c169ca3d9144349770a0baf56d6267d5ac2e8505878838c233561961c0f1f4c5dee9585e241ee730346935134162652368f735f3f9c8cf20fa43272bc99f0e68 SHA512 8c853221761199b8d3a07c38bf4ca3c355fb5618c6c0edeccd55ad88ea68907cd8d80075824bfd83ad88c9c06a2ddf46e52d88934670040bf74262128e241e89
diff --git a/dev-python/rich/rich-10.15.0.ebuild b/dev-python/rich/rich-10.15.0.ebuild
new file mode 100644
index 000000000000..05ddc3dab2e6
--- /dev/null
+++ b/dev-python/rich/rich-10.15.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Python library for renrering rich text, tables, etc. to the terminal"
+HOMEPAGE="https://github.com/willmcgugan/rich"
+SRC_URI="https://github.com/willmcgugan/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/commonmark[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest
+
+pkg_postinst() {
+ optfeature "integration with HTML widgets for Jupyter" dev-python/ipywidgets
+}