summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-27 09:16:46 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-27 10:12:11 +0200
commit8a0162ebb398eb13cc885ce0ab0cf32914540cb5 (patch)
tree15eaf66bd73670f4d3d635f5ff945492ffcfb76e
parentdev-python/setuptools-rust: Bump to 1.3.0 (diff)
downloadgentoo-8a0162ebb398eb13cc885ce0ab0cf32914540cb5.tar.gz
gentoo-8a0162ebb398eb13cc885ce0ab0cf32914540cb5.tar.bz2
gentoo-8a0162ebb398eb13cc885ce0ab0cf32914540cb5.zip
dev-python/google-api-python-client: Bump to 2.46.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/google-api-python-client/Manifest1
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.46.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index 206fee054ab7..7725b3803c65 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1,2 +1,3 @@
DIST google-api-python-client-2.44.0.tar.gz 29961288 BLAKE2B 3bb7d421c76180009c7105d693edc32c5f6af7d853cf9f70d18001976e854c343d6d9e03ad5210562a1c1c17c5127b6d96d2b12128997a8007bc027eb10c841d SHA512 8a12684117a1bdd6b72ec6fce2e7d1e48115e05788e39c8aaad8f6095e4bdc3245f6c471044e6b0e6983210f8cd0328bb9ef459f55c4c9b973a89a658a30677b
DIST google-api-python-client-2.45.0.tar.gz 30011332 BLAKE2B e8a734a7aea1152ac92427de7059fa59216ba96c5fc68976b341fe0fcdd8851cbbcf1eb8e9cdc37cd18eec5cce0e8f87d3832b0df39c8795f3363f61c457a17e SHA512 b0adabae6ea29390fa7506cd7b846b8499591e49ecb247818b7304683c4ea3def25203a106b371ceff5e576c84f3ab207ffd428cb7b1b543b170c2ef0ea731d4
+DIST google-api-python-client-2.46.0.tar.gz 30051613 BLAKE2B c1ada6b9e59ec269e6584c6555af17b1e0561e9d3e273c56b554280ee32e3db9b0e96677fc6490990d2944d532d1eb908fa9c45e38faee942c80fa1c10a10bcb SHA512 fec085668fe9ad842c2b4ffc74165af459f99e91758580e83b3270cecd6c3faaba47f27113655859a2dd616ad42cd652541230eb515ed14ff759ae9891eed03b
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.46.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.46.0.ebuild
new file mode 100644
index 000000000000..9ffc1aa432ce
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.46.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="https://github.com/googleapis/google-api-python-client"
+SRC_URI="
+ https://github.com/googleapis/google-api-python-client/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ )
+
+ epytest tests
+}