summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2018-04-15 11:03:12 +0200
committerPacho Ramos <pacho@gentoo.org>2018-04-15 11:11:25 +0200
commit8a0f15c994f4d27231cad05905f983f00b2d49c4 (patch)
tree0976581b22e1e4c1931e1367a4f8bf9385a06416
parentgames-arcade/apricots: Drop old (diff)
downloadgentoo-8a0f15c9.tar.gz
gentoo-8a0f15c9.tar.bz2
gentoo-8a0f15c9.zip
games-arcade/ascii-invaders: Stop using games.eclass
Package-Manager: Portage-2.3.28, Repoman-2.3.9
-rw-r--r--games-arcade/ascii-invaders/ascii-invaders-0.1b-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/games-arcade/ascii-invaders/ascii-invaders-0.1b-r1.ebuild b/games-arcade/ascii-invaders/ascii-invaders-0.1b-r1.ebuild
new file mode 100644
index 000000000000..5c6a25c0ed44
--- /dev/null
+++ b/games-arcade/ascii-invaders/ascii-invaders-0.1b-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Space invaders clone, using ncurses library"
+HOMEPAGE="https://packages.gentoo.org/package/games-arcade/ascii-invaders"
+SRC_URI="mirror://gentoo/invaders${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~mips ~ppc64 ~x86 ~x86-fbsd ~ppc-macos"
+IUSE=""
+
+RDEPEND="sys-libs/ncurses:0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/invaders"
+
+src_prepare() {
+ default
+ rm -f Makefile
+}
+
+src_compile() {
+ emake LDLIBS="$(pkg-config ncurses --libs)" invaders
+}
+
+src_install() {
+ newbin invaders ${PN}
+ einstalldocs
+}