summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNick Sarnie <sarnex@gentoo.org>2022-11-24 10:48:40 -0500
committerNick Sarnie <sarnex@gentoo.org>2022-11-24 10:49:43 -0500
commit8a5255d01d4eda811fd26e1be4124b06c34bff33 (patch)
treed50fe40ed83d03e9146077bf4539d676ba0cd6a5
parentdev-util/umockdev: Version bump to 0.17.15 (diff)
downloadgentoo-8a5255d01d4eda811fd26e1be4124b06c34bff33.tar.gz
gentoo-8a5255d01d4eda811fd26e1be4124b06c34bff33.tar.bz2
gentoo-8a5255d01d4eda811fd26e1be4124b06c34bff33.zip
media-libs/vulkan-layers: You have got to be kidding me
Bug: https://bugs.gentoo.org/882727 Signed-off-by: Nick Sarnie <sarnex@gentoo.org>
-rw-r--r--media-libs/vulkan-layers/files/vulkan-layers-1.3.231-Make-BUILD_WERROR-actually-work.patch19
-rw-r--r--media-libs/vulkan-layers/vulkan-layers-1.3.231.ebuild4
2 files changed, 22 insertions, 1 deletions
diff --git a/media-libs/vulkan-layers/files/vulkan-layers-1.3.231-Make-BUILD_WERROR-actually-work.patch b/media-libs/vulkan-layers/files/vulkan-layers-1.3.231-Make-BUILD_WERROR-actually-work.patch
new file mode 100644
index 00000000000..4bd9abf89a8
--- /dev/null
+++ b/media-libs/vulkan-layers/files/vulkan-layers-1.3.231-Make-BUILD_WERROR-actually-work.patch
@@ -0,0 +1,19 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index e3985fc6d..ea8d47bb3 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -170,14 +170,6 @@ if(${CMAKE_C_COMPILER_ID} MATCHES "(GNU|Clang)")
+ -fno-strict-aliasing
+ -fno-builtin-memcmp)
+
+- # Treat warnings as errors for versions of GCC and c++11-compliant Clang versions that are shipped on Ubuntu 18.04 or older.
+- if(BUILD_WERROR OR
+- (${CMAKE_CXX_COMPILER_ID} STREQUAL "GNU" AND CMAKE_CXX_COMPILER_VERSION VERSION_LESS_EQUAL 7.3.0) OR
+- (${CMAKE_CXX_COMPILER_ID} STREQUAL "Clang" AND CMAKE_CXX_COMPILER_VERSION VERSION_GREATER_EQUAL 6.0.0))
+- add_compile_options(-Werror)
+- endif()
+-
+-
+ set(CMAKE_C_STANDARD 99)
+
+ # For GCC version 7.1 or greater, we need to disable the implicit fallthrough warning since there's no consistent way to satisfy
diff --git a/media-libs/vulkan-layers/vulkan-layers-1.3.231.ebuild b/media-libs/vulkan-layers/vulkan-layers-1.3.231.ebuild
index 8858c9eb415..aaf3971f38e 100644
--- a/media-libs/vulkan-layers/vulkan-layers-1.3.231.ebuild
+++ b/media-libs/vulkan-layers/vulkan-layers-1.3.231.ebuild
@@ -24,7 +24,9 @@ LICENSE="Apache-2.0"
SLOT="0"
IUSE="wayland X"
-PATCHES=( "${FILESDIR}/${P}-cmake-Cleanup-find_package-SPIRV-code.patch" )
+PATCHES=( "${FILESDIR}/${P}-cmake-Cleanup-find_package-SPIRV-code.patch"
+ "${FILESDIR}/${P}-Make-BUILD_WERROR-actually-work.patch"
+)
BDEPEND=">=dev-util/cmake-3.10.2"
RDEPEND="~dev-util/spirv-tools-${PV}:=[${MULTILIB_USEDEP}]"