summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-18 01:48:06 +0100
committerSam James <sam@gentoo.org>2022-06-18 01:48:06 +0100
commit8a5e17b48f908441b70e267a1748cd3e6f19cbbf (patch)
tree4c98341aaf2af409ecb7803e9daf04ed0bdcf950
parentapp-forensics/magicrescue: add missing Perl BDEPEND (diff)
downloadgentoo-8a5e17b48f908441b70e267a1748cd3e6f19cbbf.tar.gz
gentoo-8a5e17b48f908441b70e267a1748cd3e6f19cbbf.tar.bz2
gentoo-8a5e17b48f908441b70e267a1748cd3e6f19cbbf.zip
dev-vcs/python-gitlab: add some missing test deps
Closes: https://bugs.gentoo.org/728672 Closes: https://bugs.gentoo.org/852698 Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-vcs/python-gitlab/python-gitlab-3.5.0.ebuild7
1 files changed, 4 insertions, 3 deletions
diff --git a/dev-vcs/python-gitlab/python-gitlab-3.5.0.ebuild b/dev-vcs/python-gitlab/python-gitlab-3.5.0.ebuild
index 09a91036c8e1..6f782bcbdbae 100644
--- a/dev-vcs/python-gitlab/python-gitlab-3.5.0.ebuild
+++ b/dev-vcs/python-gitlab/python-gitlab-3.5.0.ebuild
@@ -18,16 +18,17 @@ fi
LICENSE="LGPL-3"
SLOT="0"
-IUSE="test"
BDEPEND="test? (
dev-python/httmock[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}] )"
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/responses[${PYTHON_USEDEP}]
+ )"
RDEPEND=">=dev-python/requests-2.25.1[${PYTHON_USEDEP}]
>=dev-python/requests-toolbelt-0.9.1[${PYTHON_USEDEP}]"
-distutils_enable_tests unittest
+distutils_enable_tests pytest
python_install_all() {
distutils-r1_python_install_all