summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarty E. Plummer <hanetzer@startmail.com>2018-04-20 04:10:49 -0500
committerDavid Seifert <soap@gentoo.org>2018-04-20 22:00:57 +0200
commit8b8dfee6f3f4240ce6844f73b05b022716043a2b (patch)
tree8be311efd6b4a5170802a1f9cee344d0b019f044
parentmedia-gfx/nvidia-texture-tools: epatch->eapply (diff)
downloadgentoo-8b8dfee6f3f4240ce6844f73b05b022716043a2b.tar.gz
gentoo-8b8dfee6f3f4240ce6844f73b05b022716043a2b.tar.bz2
gentoo-8b8dfee6f3f4240ce6844f73b05b022716043a2b.zip
net-irc/epic5: epatch->PATCHES=()
Reworked a patch to be -p1 applicable. Also, this ebuild cannot be built at due to missing xlocale.h on >=glibc-2.26, with or without my changes. Package-Manager: Portage-2.3.28, Repoman-2.3.9
-rw-r--r--net-irc/epic5/epic5-1.1.10-r2.ebuild22
-rw-r--r--net-irc/epic5/files/epic5-1.1.10-socks5-libsocks.patch9
2 files changed, 13 insertions, 18 deletions
diff --git a/net-irc/epic5/epic5-1.1.10-r2.ebuild b/net-irc/epic5/epic5-1.1.10-r2.ebuild
index 323296c7006d..289bab3402a8 100644
--- a/net-irc/epic5/epic5-1.1.10-r2.ebuild
+++ b/net-irc/epic5/epic5-1.1.10-r2.ebuild
@@ -5,7 +5,7 @@ EAPI=6
USE_RUBY="ruby22 ruby23"
-inherit autotools eutils multilib ruby-single toolchain-funcs
+inherit autotools ruby-single toolchain-funcs
DESCRIPTION="Epic5 IRC Client"
SRC_URI="ftp://ftp.epicsol.org/pub/epic/EPIC5-PRODUCTION/${P}.tar.bz2"
@@ -30,17 +30,17 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${P}
-src_prepare() {
- epatch \
- "${FILESDIR}"/${PN}-1.1.2-libarchive-automagic.patch \
- "${FILESDIR}"/${P}-ruby-automagic-as-needed.patch \
- "${FILESDIR}"/${P}-tcl-automagic-as-needed.patch \
- "${FILESDIR}"/${PN}-1.1.2-perl-automagic-as-needed.patch \
- "${FILESDIR}"/${P}-without-localdir.patch \
- "${FILESDIR}"/${P}-socks5-libsocks.patch
-
- eapply_user
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.2-libarchive-automagic.patch \
+ "${FILESDIR}"/${P}-ruby-automagic-as-needed.patch \
+ "${FILESDIR}"/${P}-tcl-automagic-as-needed.patch \
+ "${FILESDIR}"/${PN}-1.1.2-perl-automagic-as-needed.patch \
+ "${FILESDIR}"/${P}-without-localdir.patch \
+ "${FILESDIR}"/${P}-socks5-libsocks.patch
+)
+src_prepare() {
+ default
eautoconf
}
diff --git a/net-irc/epic5/files/epic5-1.1.10-socks5-libsocks.patch b/net-irc/epic5/files/epic5-1.1.10-socks5-libsocks.patch
index c2555c059e79..4aef0c7d6af3 100644
--- a/net-irc/epic5/files/epic5-1.1.10-socks5-libsocks.patch
+++ b/net-irc/epic5/files/epic5-1.1.10-socks5-libsocks.patch
@@ -1,13 +1,8 @@
From: Nathan Phillip Brink <binki@gentoo.org>
Subject: Use -lsocks instead of -lsocks5 for `./configure --with-socks5`.
-Index: configure.in
-===================================================================
-RCS file: /home/cvs/repository/epic5/configure.in,v
-retrieving revision 1.101
-diff -u -b -B -u -r1.101 configure.in
---- configure.in 9 Apr 2014 17:51:06 -0000 1.101
-+++ configure.in 4 Sep 2014 00:18:00 -0000
+--- a/configure.in
++++ b/configure.in
@@ -861,7 +861,7 @@
AC_MSG_CHECKING(whether to support SOCKS)