summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2022-09-30 14:27:36 -0600
committerChristoph Junghans <junghans@gentoo.org>2022-09-30 14:28:18 -0600
commit8bfd53ae46426bf9eb15cc0a6415d03252c3f4ff (patch)
tree7b6273755f8b22c27d0b22f00e58cda6ae31f17e
parentdev-lang/php: Version bump for 8.0.24 (diff)
downloadgentoo-8bfd53ae.tar.gz
gentoo-8bfd53ae.tar.bz2
gentoo-8bfd53ae.zip
muParser: wchar support
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Christoph Junghans <junghans@gentoo.org>
-rw-r--r--dev-cpp/muParser/metadata.xml3
-rw-r--r--dev-cpp/muParser/muParser-2.3.3-r1.ebuild41
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-cpp/muParser/metadata.xml b/dev-cpp/muParser/metadata.xml
index c81547b2e58d..05a26448f3c7 100644
--- a/dev-cpp/muParser/metadata.xml
+++ b/dev-cpp/muParser/metadata.xml
@@ -14,4 +14,7 @@
<remote-id type="sourceforge">muparser</remote-id>
<remote-id type="github">beltoforion/muparser</remote-id>
</upstream>
+ <use>
+ <flag name="wchar">Add support for wide character (wchar_t)</flag>
+ </use>
</pkgmetadata>
diff --git a/dev-cpp/muParser/muParser-2.3.3-r1.ebuild b/dev-cpp/muParser/muParser-2.3.3-r1.ebuild
new file mode 100644
index 000000000000..56484900d164
--- /dev/null
+++ b/dev-cpp/muParser/muParser-2.3.3-r1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+# The upstream tag is v2.3.3-1 instead of v2.3.3
+suffix="-1"
+
+DESCRIPTION="Library for parsing mathematical expressions"
+HOMEPAGE="https://beltoforion.de/en/muparser/"
+SRC_URI="https://github.com/beltoforion/muparser/archive/refs/tags/v${PV}${suffix}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/muparser-${PV}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc openmp test wchar"
+RESTRICT="!test? ( test )"
+
+S="${S}${suffix}"
+
+PATCHES=(
+)
+
+src_configure() {
+ mycmakeargs=(
+ -DENABLE_OPENMP=$(usex openmp)
+ -DENABLE_WIDE_CHAR=$(usex wchar)
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ cmake_src_compile test
+}
+
+src_install() {
+ cmake_src_install
+}