summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-11-04 04:15:24 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-11-04 04:23:38 -0400
commit8bfd676e53ebd645a3794111f283da85ea9d565c (patch)
tree65c8a523cc8901fd0e47d144333c064d534278f2
parentdev-python/myst_parser: Stabilize 0.18.1 ALLARCHES, #879437 (diff)
downloadgentoo-8bfd676e53ebd645a3794111f283da85ea9d565c.tar.gz
gentoo-8bfd676e53ebd645a3794111f283da85ea9d565c.tar.bz2
gentoo-8bfd676e53ebd645a3794111f283da85ea9d565c.zip
media-sound/cava: add 0.8.3
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
-rw-r--r--media-sound/cava/Manifest1
-rw-r--r--media-sound/cava/cava-0.8.3.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/media-sound/cava/Manifest b/media-sound/cava/Manifest
index 2a24285f08f5..3f0a124be904 100644
--- a/media-sound/cava/Manifest
+++ b/media-sound/cava/Manifest
@@ -1 +1,2 @@
DIST cava-0.8.2.tar.gz 103930 BLAKE2B feeb8313bd9b74029d101acaecfeed02e449cc29dceb2c119d7deef65befae418526274e6bad14dc0df7eaed90850ecae4a4064a414d94950ab3c24943281017 SHA512 8ab146987324fad97dea5e9fd893de6c12b00cbb074d835c1e334d75c0d32cb4cbbc13cf72f7899191ebd5d346505b2639dcad5312e5ab00975b29a006ba41b3
+DIST cava-0.8.3.tar.gz 104797 BLAKE2B 0617273669fbd8d1c122e6b19975d54d42b5779339de89613b4fe5d6087bcf0ff93afe6234af238e489d6b72c3eca481140105000951ef007cc864b77ef49b65 SHA512 cd176428ff293572325d21769fd4fdb666b6301e0fe5c7a2c53af2399a26b3fd10e83647f9c9cc318f4c69cc28835323fb949cd76340c14670df8b544bffa0f0
diff --git a/media-sound/cava/cava-0.8.3.ebuild b/media-sound/cava/cava-0.8.3.ebuild
new file mode 100644
index 000000000000..de716fb01129
--- /dev/null
+++ b/media-sound/cava/cava-0.8.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Console-based Audio Visualizer for Alsa"
+HOMEPAGE="https://github.com/karlstav/cava/"
+SRC_URI="https://github.com/karlstav/cava/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa +ncurses portaudio pulseaudio sdl sndio"
+
+RDEPEND="
+ dev-libs/iniparser:4
+ sci-libs/fftw:3.0=
+ alsa? ( media-libs/alsa-lib )
+ ncurses? ( sys-libs/ncurses:= )
+ portaudio? ( media-libs/portaudio )
+ pulseaudio? ( media-libs/libpulse )
+ sdl? ( media-libs/libsdl2[opengl,video] )
+ sndio? ( media-sound/sndio:= )"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.0-gentoo-iniparser4.patch
+)
+
+src_prepare() {
+ default
+
+ echo ${PV} > version || die
+ eautoreconf
+}
+
+src_configure() {
+ local econfargs=(
+ $(use_enable alsa input-alsa)
+ $(use_enable portaudio input-portaudio)
+ $(use_enable pulseaudio input-pulse)
+ $(use_enable sndio input-sndio)
+
+ $(use_enable ncurses output-ncurses)
+ $(use_enable sdl output-sdl)
+
+ GENTOO_SYSROOT="${ESYSROOT}" # see iniparser4.patch
+ )
+
+ econf "${econfargs[@]}"
+}
+
+pkg_postinst() {
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "A default ~/.config/cava/config will be created after initial"
+ elog "use of ${PN}, see it and ${EROOT}/usr/share/doc/${PF}/README*"
+ elog "for configuring audio input and more."
+ fi
+}