summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-06-05 17:39:48 +0200
committerManuel Rüger <mrueg@gentoo.org>2017-06-05 17:39:48 +0200
commit8c33ba5c7aa287d043d5b8e8fe4c656adc9695e6 (patch)
tree6ba19d8e33cb10a2246dc63bce334e739ac21942
parentapp-misc/go-jira: Drop unused user.eclass (diff)
downloadgentoo-8c33ba5c7aa287d043d5b8e8fe4c656adc9695e6.tar.gz
gentoo-8c33ba5c7aa287d043d5b8e8fe4c656adc9695e6.tar.bz2
gentoo-8c33ba5c7aa287d043d5b8e8fe4c656adc9695e6.zip
x11-misc/xkeyboard-config: Version bump to 2.21
Package-Manager: Portage-2.3.6, Repoman-2.3.2
-rw-r--r--x11-misc/xkeyboard-config/Manifest1
-rw-r--r--x11-misc/xkeyboard-config/xkeyboard-config-2.21.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/x11-misc/xkeyboard-config/Manifest b/x11-misc/xkeyboard-config/Manifest
index 46846b6ecb45..578d1e7343ed 100644
--- a/x11-misc/xkeyboard-config/Manifest
+++ b/x11-misc/xkeyboard-config/Manifest
@@ -1 +1,2 @@
DIST xkeyboard-config-2.20.tar.bz2 978275 SHA256 d1bfc72553c4e3ef1cd6f13eec0488cf940498b612ab8a0b362e7090c94bc134 SHA512 29584096874cf8f1444ed00374150fb186e9a74221b384d779bcf01c0762977f8a6a1b3dfa37acd560667a79cc80d4c0d39729b7dc21809520a7254026439db4 WHIRLPOOL f03b1e05e3c2897cab96bf569e97bb1095f13a8ce1eb2aaae4ae0ff1a588974c9e7e5bd066026f95a2c4939d0bc151aad77a233b7dbf994e3caeb50a5210f539
+DIST xkeyboard-config-2.21.tar.bz2 994972 SHA256 30c17049fae129fc14875656da9aa3099e3031d6ce0ee1d77aae190fd9edcec5 SHA512 c8c3da9d78365878b051bcfecc7c51e89c5aa15e6e3ba5e8c84612eaca4ca7741702c023f9571ac04c865f2951a7ca33f4fbbedb3baf6c76441ebf59c4e41068 WHIRLPOOL 4addfc267203bf3e5d66d9b8cb07c62bba75ddf42fe0cbb832d94373941c768d136e6724d28433728ecde3d0c9eb39f66e65ae72e0462d1c94e86b1d7ac9959e
diff --git a/x11-misc/xkeyboard-config/xkeyboard-config-2.21.ebuild b/x11-misc/xkeyboard-config/xkeyboard-config-2.21.ebuild
new file mode 100644
index 000000000000..f164976b13df
--- /dev/null
+++ b/x11-misc/xkeyboard-config/xkeyboard-config-2.21.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+XORG_STATIC=no
+inherit xorg-2
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/xkeyboard-config"
+
+DESCRIPTION="X keyboard configuration database"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/XKeyboardConfig"
+[[ ${PV} == *9999* ]] || SRC_URI="${XORG_BASE_INDIVIDUAL_URI}/data/${PN}/${P}.tar.bz2"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE=""
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="!<x11-apps/xkbcomp-1.2.3
+ !<x11-libs/libX11-1.4.3"
+DEPEND="
+ sys-devel/gettext
+ dev-util/intltool"
+
+XORG_CONFIGURE_OPTIONS=(
+ --with-xkb-base="${EPREFIX}/usr/share/X11/xkb"
+ --enable-compat-rules
+ # do not check for runtime deps
+ --disable-runtime-deps
+ --with-xkb-rules-symlink=xorg
+)
+
+src_prepare() {
+ xorg-2_src_prepare
+ if [[ ${XORG_EAUTORECONF} != no ]]; then
+ intltoolize --copy --automake || die
+ fi
+}