summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNaohiro Aota <naota@gentoo.org>2016-01-24 19:20:20 +0900
committerNaohiro Aota <naota@gentoo.org>2016-01-24 19:20:52 +0900
commit8c95dbfd40f83ded759fae4c8c67c2136d7239b8 (patch)
tree706b6396c9992c45de726bd01e61b0a0eb0e9793
parentdev-ruby/pluggaloid: add new package (diff)
downloadgentoo-8c95dbfd40f83ded759fae4c8c67c2136d7239b8.tar.gz
gentoo-8c95dbfd40f83ded759fae4c8c67c2136d7239b8.tar.bz2
gentoo-8c95dbfd40f83ded759fae4c8c67c2136d7239b8.zip
dev-ruby/totoridipjp: add new package
Package-Manager: portage-2.2.27
-rw-r--r--dev-ruby/totoridipjp/Manifest1
-rw-r--r--dev-ruby/totoridipjp/metadata.xml11
-rw-r--r--dev-ruby/totoridipjp/totoridipjp-0.1.0.ebuild22
3 files changed, 34 insertions, 0 deletions
diff --git a/dev-ruby/totoridipjp/Manifest b/dev-ruby/totoridipjp/Manifest
new file mode 100644
index 000000000000..c4c77d173363
--- /dev/null
+++ b/dev-ruby/totoridipjp/Manifest
@@ -0,0 +1 @@
+DIST totoridipjp-0.1.0.gem 7168 SHA256 93d1245c5273971c855b506a7a913d23d6f524e9d7d4494127ae1bc6174c910d SHA512 5298fe39b0705a0b913f7f6cad452be48480a6832e9451d86a7fe9a1248fe893a76af2f56c0bd6d3a65c756d4ed3fd29b4483ef82beeccfc78dcf9dbf43ed748 WHIRLPOOL 1c191cddf29755e31a6d21884f60647b91a5099e7a31a24c243f56cc9ca59d8ca05820fe6ab695698e7a7392b370f1c6266861912126eb6986dc06c95f0f4f27
diff --git a/dev-ruby/totoridipjp/metadata.xml b/dev-ruby/totoridipjp/metadata.xml
new file mode 100644
index 000000000000..46ded822aa49
--- /dev/null
+++ b/dev-ruby/totoridipjp/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ruby</herd>
+ <maintainer>
+ <email>naota@gentoo.org</email>
+ </maintainer>
+ <upstream>
+ <remote-id type="rubygems">delayer-deferred</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ruby/totoridipjp/totoridipjp-0.1.0.ebuild b/dev-ruby/totoridipjp/totoridipjp-0.1.0.ebuild
new file mode 100644
index 000000000000..b7ef079b14a7
--- /dev/null
+++ b/dev-ruby/totoridipjp/totoridipjp-0.1.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+USE_RUBY="ruby20 ruby21 ruby22"
+
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+DESCRIPTION="A ruby binding to use totori.dip.jp Web API"
+HOMEPAGE="https://rubygems.org/gems/totoridipjp"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+all_ruby_prepare() {
+ rm -fvr bin/ || die
+}