summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2021-10-04 11:37:39 +0200
committerJakov Smolić <jsmolic@gentoo.org>2021-10-04 11:37:39 +0200
commit8c9fd1d6492d666e0126d0e621e1d54cd9f0d0bb (patch)
tree46546bcfdc7fb668e28f0176e4e95e5ca2a65fb8
parentsci-libs/hdf5: ROS3 support (diff)
downloadgentoo-8c9fd1d6492d666e0126d0e621e1d54cd9f0d0bb.tar.gz
gentoo-8c9fd1d6492d666e0126d0e621e1d54cd9f0d0bb.tar.bz2
gentoo-8c9fd1d6492d666e0126d0e621e1d54cd9f0d0bb.zip
sci-libs/libxc: Version bump to 5.1.6
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
-rw-r--r--sci-libs/libxc/Manifest1
-rw-r--r--sci-libs/libxc/libxc-5.1.6.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/sci-libs/libxc/Manifest b/sci-libs/libxc/Manifest
index c31f10f3ee31..198b182adf29 100644
--- a/sci-libs/libxc/Manifest
+++ b/sci-libs/libxc/Manifest
@@ -1,2 +1,3 @@
DIST libxc-5.1.0.tar.gz 42951890 BLAKE2B 32ce8d15547882455e01cbf9d4ee8780b97059d5b710f25b799779a5efe7326c376a53111102f3d5e0853bb89ba1f4dd9c2f219cfb4d3f91a2f6e1100f8fb47a SHA512 615b82290e87a48484f6dbe41cd8f1538ba6201b99fc97be2db64b66232fa4349fe6cebfb51566098db3cabd7aff662bb7ace43a811507bff2e93afd03d56ce4
DIST libxc-5.1.4.tar.gz 43036222 BLAKE2B 10348ccd2e8e512bf576a03eb19bf714ae4f0e590ae3a7266ae8f46c42ee12ef91e049f0007ce42023e7f13c865fedef6d1ab0fb76195ca47f62a50702741c49 SHA512 ef7f44e773a0a8a9c1a53ddd12301e123f9a4606f22420cf011d579314c1bf3164b82299aca0ef32cb130b380e5e9534d4fcc658c549ac4cb8b6f86d025cfe1e
+DIST libxc-5.1.6.tar.gz 45121466 BLAKE2B 393c85b49b1cc515abd4767a01cc56958585aac74d9913f60c304f102e76c0f3903dab326779ea7e466c19389309b2bcf49a4e0833d8f869a185b6143e1ecf29 SHA512 7e65753ca93c2174e3644f519651c59305b2fc4919de99ca2278c42a359641ced73b5c661c5315fe73b55a69ac4b7568ab1be754fc06b40bdf790881ba3ed2cb
diff --git a/sci-libs/libxc/libxc-5.1.6.ebuild b/sci-libs/libxc/libxc-5.1.6.ebuild
new file mode 100644
index 000000000000..54a6f584a57e
--- /dev/null
+++ b/sci-libs/libxc/libxc-5.1.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools fortran-2
+
+DESCRIPTION="A library of exchange-correlation functionals for use in DFT"
+HOMEPAGE="https://octopus-code.org/wiki/Libxc"
+SRC_URI="https://gitlab.com/libxc/libxc/-/archive/${PV}/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux"
+IUSE="fortran test"
+RESTRICT="!test? ( test )"
+
+pkg_setup() {
+ use fortran && fortran-2_pkg_setup
+}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-shared \
+ --disable-static \
+ $(use_enable fortran)
+}
+
+src_install() {
+ default
+ dodoc ChangeLog.md
+
+ # no static archives
+ find "${ED}" -name '*.la' -type f -delete || die
+}