summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2019-10-12 10:57:32 +0200
committerHans de Graaff <graaff@gentoo.org>2019-10-12 10:57:51 +0200
commit8cd960a480b0d64cb791c802867c940f16b3b4dc (patch)
tree802b9a01e787ad2d87429f97b61a9121af0887b5
parentapp-text/sgml-common: sh stable wrt bug #697528 (diff)
downloadgentoo-8cd960a480b0d64cb791c802867c940f16b3b4dc.tar.gz
gentoo-8cd960a480b0d64cb791c802867c940f16b3b4dc.tar.bz2
gentoo-8cd960a480b0d64cb791c802867c940f16b3b4dc.zip
dev-ruby/sassc: add 2.2.1
Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
-rw-r--r--dev-ruby/sassc/Manifest1
-rw-r--r--dev-ruby/sassc/sassc-2.2.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-ruby/sassc/Manifest b/dev-ruby/sassc/Manifest
index 068539fa3630..3f31a6490fd0 100644
--- a/dev-ruby/sassc/Manifest
+++ b/dev-ruby/sassc/Manifest
@@ -1 +1,2 @@
DIST sassc-2.0.1.gem 357888 BLAKE2B 670a622edc065abd7124a413bff3e32e524703cd3343ae7ffd1439af075e04d513ee125ddbd9ff81ffd7eadbb2dd935a83dc71334252b681fb478da9aad06181 SHA512 cece2741e316eeb4684a5650627bb2a9f161bfd99a3c93c2bf8b7d40f47ff064ee837831b1f9ad77d9e321bbd9874301762c9f0519b2b42658cbea6fd7240fcd
+DIST sassc-2.2.1.gem 302080 BLAKE2B 626601d2b22f91f354a4ddf7a68e4463b0a56b0a79e5d2ca122a083101146dac32699e348fd4573ef4ba76a430470ecd39427a8542caec931a8e16b26a23bb70 SHA512 728ad274363fd79aedee74fb6d4dbfc60f31b334e1a8054943ccf9cfa534fa3465abb00a2bd3020e198d287327058890411bb1983da6dc5dc3c4413b1936e2eb
diff --git a/dev-ruby/sassc/sassc-2.2.1.ebuild b/dev-ruby/sassc/sassc-2.2.1.ebuild
new file mode 100644
index 000000000000..4d00f99db555
--- /dev/null
+++ b/dev-ruby/sassc/sassc-2.2.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="none"
+RUBY_FAKEGEM_DOCDIR="doc"
+RUBY_FAKEGEM_EXTRADOC="README.md"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Use libsass with Ruby"
+HOMEPAGE="https://github.com/sass/sassc-ruby"
+LICENSE="MIT"
+
+KEYWORDS="~amd64"
+SLOT="2"
+IUSE=""
+
+RDEPEND+=">=dev-libs/libsass-3.6.1"
+
+ruby_add_rdepend "
+ >=dev-ruby/ffi-1.9.6
+"
+
+ruby_add_bdepend "test? (
+ dev-ruby/test_construct
+ dev-ruby/minitest-around
+)"
+
+all_ruby_prepare() {
+ # Use unbundled libsass
+ rm -rf ext || die
+
+ sed -i -e '/ffi_lib/ s:__dir__:"/usr/lib64":' \
+ lib/sassc/native.rb || die
+
+ # Avoid version-specific test so newer libsass versions can be used.
+ sed -i -e '/test_it_reports_the_libsass_version/,/end/ s:^:#:' test/native_test.rb || die
+
+ sed -i -e '/pry/ s:^:#:' test/test_helper.rb || die
+}
+
+each_ruby_test() {
+ ${RUBY} -Ilib:.:test -e 'Dir["test/**/*_test.rb"].each{|f| require f}' || die
+}