summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-01 09:19:55 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-01 09:19:55 +0200
commit8d45a80ad75bc39696c1cac22b0519c05b0e0b0f (patch)
tree7f52415caa321d37e0a68e31f0fca507be9a8760
parentdev-python/apispec: Bump to 4.4.0 (diff)
downloadgentoo-8d45a80ad75bc39696c1cac22b0519c05b0e0b0f.tar.gz
gentoo-8d45a80ad75bc39696c1cac22b0519c05b0e0b0f.tar.bz2
gentoo-8d45a80ad75bc39696c1cac22b0519c05b0e0b0f.zip
net-misc/youtube-dl: Bump to 2021.04.01
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--net-misc/youtube-dl/Manifest1
-rw-r--r--net-misc/youtube-dl/youtube-dl-2021.04.01.ebuild71
2 files changed, 72 insertions, 0 deletions
diff --git a/net-misc/youtube-dl/Manifest b/net-misc/youtube-dl/Manifest
index d174b6b299c4..c93af7f0588a 100644
--- a/net-misc/youtube-dl/Manifest
+++ b/net-misc/youtube-dl/Manifest
@@ -1,3 +1,4 @@
DIST youtube-dl-2021.03.14.tar.gz 3306486 BLAKE2B 6c5705319e405e4bb098c72b696d41ba655f6e38884012b00da0a5f66a68ac49e34b1906cf22c5444ba62aed4f74d93517b81471b9ddebdc1ee72b3ae190a3a9 SHA512 12f08eaa8a4ba3598ab9caa1c313982e62168a4e4afa3f613f7dee0efef3bcfee701ffd525f1dd1ba1da66aa71bcfd8bed91fa64a8c7473aca6b9e6a09282a70
DIST youtube-dl-2021.03.25.tar.gz 3313712 BLAKE2B 323ef3e1eda1549500cbea29bcbb55821b5ed6730d65100d6fdd95be4a5d98bb155a519c47fc42883889fcb03bda559edfbd52e38d999fa7fc19ad2aefb7f902 SHA512 77b3beb907081fd682c69d280ddc69610ef59d264b089597481cb4f57dfbac5abc90b54b38bc3691817e0f7a6a3df35b59035f49d5d22e461db87086081f426c
DIST youtube-dl-2021.03.31.tar.gz 3315008 BLAKE2B a03d50866e3159155234b82d7662874d1fa427498f7e649da007af50dfb0e89b0373549a85bf76266fe978128ba37dfc547016fd1c8b163c638d6621defdcbc4 SHA512 9f594aef9e5a490d1d5af6135a9df0fa6d0e050303fc7216ca36b29d176f018fab3f37b344ad6db6ebf9d650d25343cd671d4d54999eb34b39a020dadbb77d3f
+DIST youtube-dl-2021.04.01.tar.gz 3315743 BLAKE2B 01cd9496116215dd95083060f61134b32b139be1c6002e79a51c7b7f33f933d172608a7d57e95f00f1c14f0c71f4d7a60fcea67c5535c74d73d635e23e7058dc SHA512 138307b14b9ca18a1d55d16d4ae5d179e3244a9e270dedd732a14bb9250665741a9a90ecb1887308dcebfc2e448df28a505168b2b3afed7caeddacf4da8bce53
diff --git a/net-misc/youtube-dl/youtube-dl-2021.04.01.ebuild b/net-misc/youtube-dl/youtube-dl-2021.04.01.ebuild
new file mode 100644
index 000000000000..9b024e43dbba
--- /dev/null
+++ b/net-misc/youtube-dl/youtube-dl-2021.04.01.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=(python3_{7..9})
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit bash-completion-r1 distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="Download videos from YouTube.com (and more sites...)"
+HOMEPAGE="https://youtube-dl.org/ https://github.com/ytdl-org/youtube-dl/"
+SRC_URI="https://youtube-dl.org/downloads/${PV}/${P}.tar.gz"
+S=${WORKDIR}/${PN}
+
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+SLOT="0"
+
+RDEPEND="
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests nose
+
+src_prepare() {
+ sed -i -e '/flake8/d' Makefile || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ emake offlinetest
+}
+
+python_install_all() {
+ doman youtube-dl.1
+
+ newbashcomp youtube-dl.bash-completion youtube-dl
+
+ insinto /usr/share/zsh/site-functions
+ newins youtube-dl.zsh _youtube-dl
+
+ insinto /usr/share/fish/vendor_completions.d
+ doins youtube-dl.fish
+
+ distutils-r1_python_install_all
+
+ rm -r "${ED}"/usr/etc || die
+ rm -r "${ED}"/usr/share/doc/youtube_dl || die
+}
+
+pkg_postinst() {
+ elog "youtube-dl(1) / https://bugs.gentoo.org/355661 /"
+ elog "https://github.com/rg3/youtube-dl/blob/master/README.md#faq :"
+ elog
+ elog "youtube-dl works fine on its own on most sites. However, if you want"
+ elog "to convert video/audio, you'll need ffmpeg (media-video/ffmpeg)."
+ elog "On some sites - most notably YouTube - videos can be retrieved in"
+ elog "a higher quality format without sound. youtube-dl will detect whether"
+ elog "ffmpeg is present and automatically pick the best option."
+ elog
+ elog "Videos or video formats streamed via RTMP protocol can only be"
+ elog "downloaded when rtmpdump (media-video/rtmpdump) is installed."
+ elog
+ elog "Downloading MMS and RTSP videos requires either mplayer"
+ elog "(media-video/mplayer) or mpv (media-video/mpv) to be installed."
+ elog
+ elog "If you want youtube-dl to embed thumbnails from the metadata into the"
+ elog "resulting MP4 files, consider installing media-video/atomicparsley"
+}