summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJan Chren <dev.rindeal@gmail.com>2016-04-28 21:59:49 +0200
committerJason Zaman <perfinion@gentoo.org>2016-05-08 12:19:25 +0800
commit8d9f6c18c2d20221171204129573ca7bc420a974 (patch)
tree0b090b0b5e2b3565452564395dc3528ac48a9dde
parentapp-laptop/laptop-mode-tools: add name to maintainer (diff)
downloadgentoo-8d9f6c18c2d20221171204129573ca7bc420a974.tar.gz
gentoo-8d9f6c18c2d20221171204129573ca7bc420a974.tar.bz2
gentoo-8d9f6c18c2d20221171204129573ca7bc420a974.zip
net-libs/libproxy: bump to 0.4.13
Thanks-to: Arfrever Frehtes Taifersar Arahesis <arfrever.fta@gmail.com> Gentoo-Bug: 574046
-rw-r--r--net-libs/libproxy/Manifest1
-rw-r--r--net-libs/libproxy/libproxy-0.4.13.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/net-libs/libproxy/Manifest b/net-libs/libproxy/Manifest
index 81c8202d93ad..ef970e3876b5 100644
--- a/net-libs/libproxy/Manifest
+++ b/net-libs/libproxy/Manifest
@@ -1 +1,2 @@
DIST libproxy-0.4.11.tar.gz 93757 SHA256 dc3f33de54163718f82b3e7c496a7de97f8862578414b8ecaad3cbfe4821864b SHA512 563a837946a73c41e0773cec93332c6308245c0b807a40a0fb052c2445deae4a117ba2780a350c799717fd11c4dbe410183a38ea050a4f04db0b1adcb6f9ad98 WHIRLPOOL 2165fcb9a43592e1112539ff7fdd79963fc6c00821edb5d5f04d92d7d1bd884362019a2a2cd12cb412dfaee25ad8e1554a568e9818910861000666bfe81ca479
+DIST libproxy-0.4.13.tar.gz 89296 SHA256 d610bc0ef81a18ba418d759c5f4f87bf7102229a9153fb397d7d490987330ffd SHA512 babbe5e9326cb2bfdf4504662533b314f72c3475687f8b57c235614698cb18e0ed31752b834cb1d33cc94ecd3af6589684b2846e73830f0be3557c465a1f1c42 WHIRLPOOL 1b159efd7e03505c8fd7098a553ba22099cf90002730c3a6c929dbfecb95af3c175aebb93502e4286c66604f75a01d4205cd311144a97f51d425ef69f4345370
diff --git a/net-libs/libproxy/libproxy-0.4.13.ebuild b/net-libs/libproxy/libproxy-0.4.13.ebuild
new file mode 100644
index 000000000000..8601068a20e6
--- /dev/null
+++ b/net-libs/libproxy/libproxy-0.4.13.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit cmake-multilib eutils flag-o-matic mono python-r1
+
+DESCRIPTION="Library for automatic proxy configuration management"
+HOMEPAGE="https://code.google.com/p/libproxy/"
+LICENSE="LGPL-2.1+"
+
+SLOT="0"
+SRC_URI="https://${PN}.googlecode.com/files/${P}.tar.gz"
+
+KEYWORDS="~alpha ~amd64 ~amd64-linux ~arm ~arm-linux ~hppa ~ia64 ~ia64-linux ~mips ~ppc ~ppc64 ~sh ~sparc ~sparc-solaris ~x64-macos ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~x86-linux ~x86-macos ~x86-solaris"
+IUSE="gnome kde mono networkmanager perl python spidermonkey test webkit"
+
+REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )"
+
+# NOTE: mozjs/spidermonkey might still cause problems like #373397 ?
+# NOTE: webkit-gtk:3, not :2, needed for libjavascriptcoregtk support
+RDEPEND="gnome? ( >=dev-libs/glib-2.34.3:2[${MULTILIB_USEDEP}] )
+ kde? ( >=kde-base/kdelibs-4.4.5 )
+ mono? ( dev-lang/mono )
+ networkmanager? ( >=sys-apps/dbus-1.6.18-r1[${MULTILIB_USEDEP}] )
+ perl? ( dev-lang/perl:= )
+ python? ( ${PYTHON_DEPS} )
+ spidermonkey? ( >=dev-lang/spidermonkey-1.8.5:0= )
+ webkit? ( >=net-libs/webkit-gtk-1.6:3= )"
+DEPEND="${RDEPEND}
+ kde? ( dev-util/automoc )
+ >=virtual/pkgconfig-0-r1[${MULTILIB_USEDEP}]"
+# avoid dependency loop, bug #467696
+PDEPEND="networkmanager? ( net-misc/networkmanager )"
+
+src_prepare() {
+ # Gentoo's spidermonkey doesn't set Version: in mozjs18[57].pc
+ epatch "${FILESDIR}/${P}-mozjs.pc.patch"
+
+ # get-pac-test freezes when run by the ebuild, succeeds when building
+ # manually; virtualx.eclass doesn't help :(
+ epatch "${FILESDIR}/${PN}-0.4.10-disable-pac-test.patch"
+
+ epatch "${FILESDIR}"/${P}-macosx.patch
+
+ # prevent dependency loop with networkmanager, libsoup, glib-networking; bug #467696
+ epatch "${FILESDIR}/${PN}-0.4.11-avoid-nm-build-dep.patch"
+}
+
+src_configure() {
+ [[ ${CHOST} == *-solaris* ]] && append-libs -lsocket -lnsl
+
+ use python && python_setup
+ multilib-minimal_src_configure
+}
+
+multilib_src_configure() {
+ # WITH_VALA just copies the .vapi file over and needs no deps,
+ # hence always enable it unconditionally
+ local mycmakeargs=(
+ -DPERL_VENDORINSTALL=ON
+ -DCMAKE_C_FLAGS="${CFLAGS}"
+ -DCMAKE_CXX_FLAGS="${CXXFLAGS}"
+ $(cmake-utils_use_with gnome GNOME3)
+ $(multilib_is_native_abi && cmake-utils_use_with kde KDE4 \
+ || echo -DWITH_KDE4=OFF)
+ $(multilib_is_native_abi && cmake-utils_use_with mono DOTNET \
+ || echo -DWITH_DOTNET=OFF)
+ $(cmake-utils_use_with networkmanager NM)
+ $(multilib_is_native_abi && cmake-utils_use_with perl PERL \
+ || echo -DWITH_PERL=OFF)
+ $(multilib_is_native_abi && cmake-utils_use_with python PYTHON \
+ || echo -DWITH_PYTHON=OFF)
+ $(multilib_is_native_abi && cmake-utils_use_with spidermonkey MOZJS \
+ || echo -DWITH_MOZJS=OFF)
+ $(multilib_is_native_abi && cmake-utils_use_with webkit WEBKIT \
+ || echo -DWITH_WEBKIT=OFF)
+ $(multilib_is_native_abi && cmake-utils_use_with webkit WEBKIT3 \
+ || echo -DWITH_WEBKIT3=OFF)
+ -DWITH_VALA=ON
+ $(cmake-utils_use test BUILD_TESTING)
+ )
+ cmake-utils_src_configure
+}
+
+multilib_src_install_all() {
+ DOCS="AUTHORS ChangeLog NEWS README"
+ einstalldocs
+
+ if use python; then
+ python_foreach_impl python_domodule bindings/python/libproxy.py || die
+ fi
+}