summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-04 06:25:40 +0000
committerSam James <sam@gentoo.org>2021-04-04 06:32:26 +0000
commit8e15b265573db0e37f25572bfaeea860366a924b (patch)
treee7a544a0acce74a1dd320e2b5a9ead39abae0faa
parentgames-board/blokish: eutils->desktop (diff)
downloadgentoo-8e15b265573db0e37f25572bfaeea860366a924b.tar.gz
gentoo-8e15b265573db0e37f25572bfaeea860366a924b.tar.bz2
gentoo-8e15b265573db0e37f25572bfaeea860366a924b.zip
games-board/eboard: port to EAPI 7, eutils->desktop, missing deps
Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--games-board/eboard/eboard-1.1.1-r2.ebuild28
-rw-r--r--games-board/eboard/files/eboard-1.1.1-as-needed.patch4
-rw-r--r--games-board/eboard/files/eboard-1.1.1-ovflfix.patch8
3 files changed, 26 insertions, 14 deletions
diff --git a/games-board/eboard/eboard-1.1.1-r2.ebuild b/games-board/eboard/eboard-1.1.1-r2.ebuild
index b1bc8ad5f823..78fc1bebf651 100644
--- a/games-board/eboard/eboard-1.1.1-r2.ebuild
+++ b/games-board/eboard/eboard-1.1.1-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-inherit eutils toolchain-funcs
+inherit desktop toolchain-funcs
DEB_V=${PV}-4.1
EXTRAS1="eboard-extras-1pl2"
@@ -21,11 +21,23 @@ KEYWORDS="~amd64 ~x86"
IUSE="nls"
RDEPEND="
+ dev-libs/atk
+ dev-libs/glib
+ dev-libs/gobject-introspection
+ media-libs/fontconfig
+ media-libs/freetype
media-libs/libpng:0=
- x11-libs/gtk+:2"
-DEPEND="${RDEPEND}
+ sys-libs/zlib
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf
+ x11-libs/gtk+:2
+ x11-libs/pango
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
dev-lang/perl
- virtual/pkgconfig"
+ virtual/pkgconfig
+"
PATCHES=(
"${WORKDIR}"/${PN}_${DEB_V}.diff
@@ -60,7 +72,7 @@ src_install() {
newicon icon-eboard.xpm ${PN}.xpm
make_desktop_entry ${PN} ${PN} ${PN}
- cd "${WORKDIR}"/${EXTRAS1}
+ cd "${WORKDIR}"/${EXTRAS1} || die
insinto /usr/share/${PN}
doins *.png *.wav
newins extras1.conf themeconf.extras1
@@ -68,7 +80,7 @@ src_install() {
newdoc README README.extras
dodoc CREDITS
- cd "${WORKDIR}"/${EXTRAS2}
+ cd "${WORKDIR}"/${EXTRAS2} || die
doins *.png *.wav
newins extras2.conf themeconf.extras2
}
diff --git a/games-board/eboard/files/eboard-1.1.1-as-needed.patch b/games-board/eboard/files/eboard-1.1.1-as-needed.patch
index 199dd0e70a2d..bcd1c4564226 100644
--- a/games-board/eboard/files/eboard-1.1.1-as-needed.patch
+++ b/games-board/eboard/files/eboard-1.1.1-as-needed.patch
@@ -1,5 +1,5 @@
---- a/configure 2009-02-03 14:46:21.000000000 +0100
-+++ b/configure 2009-02-03 14:48:13.000000000 +0100
+--- a/configure
++++ b/configure
@@ -638,7 +638,7 @@
print CONFIGMAKE "CXX = $cxx\n";
diff --git a/games-board/eboard/files/eboard-1.1.1-ovflfix.patch b/games-board/eboard/files/eboard-1.1.1-ovflfix.patch
index b09c4dba880f..60c428d3a292 100644
--- a/games-board/eboard/files/eboard-1.1.1-ovflfix.patch
+++ b/games-board/eboard/files/eboard-1.1.1-ovflfix.patch
@@ -1,5 +1,5 @@
---- a/proto_xboard.cc 2010-11-03 16:42:15.000000000 +0100
-+++ b/proto_xboard.cc 2010-11-03 16:43:14.000000000 +0100
+--- a/proto_xboard.cc
++++ b/proto_xboard.cc
@@ -1084,7 +1084,7 @@
snprintf(EngineCommandLine,512,"crafty bookpath=%s logpath=%s tbpath=%s",
BookPath,LogPath,LogPath);
@@ -9,8 +9,8 @@
else
strcpy(EngineRunDir,"/tmp");
---- a/util.cc 2010-11-03 16:42:24.000000000 +0100
-+++ b/util.cc 2010-11-03 16:43:42.000000000 +0100
+--- a/util.cc
++++ b/util.cc
@@ -783,7 +783,7 @@
int i,n;
char cmd[1024];