summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-08-15 22:31:49 +0200
committerDavid Seifert <soap@gentoo.org>2020-08-15 22:31:49 +0200
commit8e31cbf758673271ca84f5c65f004ca2236ada23 (patch)
treef77eac9c1647797406a1bca949b9748f6bd545c1
parentdev-vcs/darcs: fix PACKAG_VERSION definition (diff)
downloadgentoo-8e31cbf758673271ca84f5c65f004ca2236ada23.tar.gz
gentoo-8e31cbf758673271ca84f5c65f004ca2236ada23.tar.bz2
gentoo-8e31cbf758673271ca84f5c65f004ca2236ada23.zip
sys-libs/ldb: Require python at build-time unconditionally
* waf requires setting up a valid python interpreter before calling waf-utils_src_configure. Closes: https://bugs.gentoo.org/733188 Closes: https://bugs.gentoo.org/737238 Closes: https://github.com/gentoo/gentoo/pull/17126 Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: David Seifert <soap@gentoo.org>
-rw-r--r--sys-libs/ldb/ldb-2.0.12-r1.ebuild8
-rw-r--r--sys-libs/ldb/ldb-2.1.4-r1.ebuild8
-rw-r--r--sys-libs/ldb/ldb-2.2.0-r1.ebuild8
3 files changed, 15 insertions, 9 deletions
diff --git a/sys-libs/ldb/ldb-2.0.12-r1.ebuild b/sys-libs/ldb/ldb-2.0.12-r1.ebuild
index 22e302e558d5..e436f29893c4 100644
--- a/sys-libs/ldb/ldb-2.0.12-r1.ebuild
+++ b/sys-libs/ldb/ldb-2.0.12-r1.ebuild
@@ -32,12 +32,13 @@ RDEPEND="
DEPEND="dev-libs/libxslt
doc? ( app-doc/doxygen )
- python? ( ${PYTHON_DEPS} )
virtual/pkgconfig
+ ${PYTHON_DEPS}
${RDEPEND}
"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
test? ( python )"
WAF_BINARY="${S}/buildtools/bin/waf"
@@ -53,7 +54,8 @@ pkg_setup() {
# Package fails to build with distcc
export DISTCC_DISABLE=1
- use python && python-single-r1_pkg_setup
+ # waf requires a python interpreter
+ python-single-r1_pkg_setup
}
src_prepare() {
diff --git a/sys-libs/ldb/ldb-2.1.4-r1.ebuild b/sys-libs/ldb/ldb-2.1.4-r1.ebuild
index 91e258a2a019..ac64906fee13 100644
--- a/sys-libs/ldb/ldb-2.1.4-r1.ebuild
+++ b/sys-libs/ldb/ldb-2.1.4-r1.ebuild
@@ -32,12 +32,13 @@ RDEPEND="
DEPEND="dev-libs/libxslt
doc? ( app-doc/doxygen )
- python? ( ${PYTHON_DEPS} )
virtual/pkgconfig
+ ${PYTHON_DEPS}
${RDEPEND}
"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
test? ( python )"
WAF_BINARY="${S}/buildtools/bin/waf"
@@ -53,7 +54,8 @@ pkg_setup() {
# Package fails to build with distcc
export DISTCC_DISABLE=1
- use python && python-single-r1_pkg_setup
+ # waf requires a python interpreter
+ python-single-r1_pkg_setup
}
src_prepare() {
diff --git a/sys-libs/ldb/ldb-2.2.0-r1.ebuild b/sys-libs/ldb/ldb-2.2.0-r1.ebuild
index 91e258a2a019..ac64906fee13 100644
--- a/sys-libs/ldb/ldb-2.2.0-r1.ebuild
+++ b/sys-libs/ldb/ldb-2.2.0-r1.ebuild
@@ -32,12 +32,13 @@ RDEPEND="
DEPEND="dev-libs/libxslt
doc? ( app-doc/doxygen )
- python? ( ${PYTHON_DEPS} )
virtual/pkgconfig
+ ${PYTHON_DEPS}
${RDEPEND}
"
-REQUIRED_USE="python? ( ${PYTHON_REQUIRED_USE} )
+REQUIRED_USE="
+ ${PYTHON_REQUIRED_USE}
test? ( python )"
WAF_BINARY="${S}/buildtools/bin/waf"
@@ -53,7 +54,8 @@ pkg_setup() {
# Package fails to build with distcc
export DISTCC_DISABLE=1
- use python && python-single-r1_pkg_setup
+ # waf requires a python interpreter
+ python-single-r1_pkg_setup
}
src_prepare() {