summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-25 14:36:38 +0000
committerSam James <sam@gentoo.org>2021-03-25 14:39:22 +0000
commit8e9639e43323449a7193ef717c85b47c70a82877 (patch)
tree3a5ebb7e2a5d1ad23e6250cd8b2b35596dedd8e1
parentdev-libs/xapian: fix cpu_flags_* default (disable) (diff)
downloadgentoo-8e9639e43323449a7193ef717c85b47c70a82877.tar.gz
gentoo-8e9639e43323449a7193ef717c85b47c70a82877.tar.bz2
gentoo-8e9639e43323449a7193ef717c85b47c70a82877.zip
dev-libs/hyperscan: fix cpu_flags_* default (disable)
We shouldn't enable CPU_FLAGS_* by default. Users don't mask or explicitly disable flags they don't have, they just enable the ones they _do_ have. Even in this case, where we NEED SSSE3, it's wrong to default it on rather than making the user aware of the requirement. Reported-by: ggabriel Signed-off-by: Sam James <sam@gentoo.org>
-rw-r--r--dev-libs/hyperscan/hyperscan-5.3.0.ebuild4
-rw-r--r--dev-libs/hyperscan/hyperscan-5.4.0.ebuild4
2 files changed, 6 insertions, 2 deletions
diff --git a/dev-libs/hyperscan/hyperscan-5.3.0.ebuild b/dev-libs/hyperscan/hyperscan-5.3.0.ebuild
index 84f3d508c036..e05b00364aaa 100644
--- a/dev-libs/hyperscan/hyperscan-5.3.0.ebuild
+++ b/dev-libs/hyperscan/hyperscan-5.3.0.ebuild
@@ -14,7 +14,7 @@ HOMEPAGE="https://www.hyperscan.io/ https://github.com/intel/hyperscan"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="cpu_flags_x86_avx2 +cpu_flags_x86_ssse3 static-libs"
+IUSE="cpu_flags_x86_avx2 cpu_flags_x86_ssse3 static-libs"
RDEPEND="dev-libs/boost"
DEPEND="${RDEPEND}"
@@ -23,6 +23,8 @@ BDEPEND="
dev-util/ragel
"
+# We can't default this to on as it's against the expectation of
+# how CPU_FLAGS_* work for users.
REQUIRED_USE="cpu_flags_x86_ssse3"
src_prepare() {
diff --git a/dev-libs/hyperscan/hyperscan-5.4.0.ebuild b/dev-libs/hyperscan/hyperscan-5.4.0.ebuild
index 6e40c26f0f8a..9cd4cf02b42e 100644
--- a/dev-libs/hyperscan/hyperscan-5.4.0.ebuild
+++ b/dev-libs/hyperscan/hyperscan-5.4.0.ebuild
@@ -14,7 +14,7 @@ HOMEPAGE="https://www.hyperscan.io/ https://github.com/intel/hyperscan"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="cpu_flags_x86_avx2 +cpu_flags_x86_ssse3 static-libs"
+IUSE="cpu_flags_x86_avx2 cpu_flags_x86_ssse3 static-libs"
RDEPEND="dev-libs/boost:="
DEPEND="${RDEPEND}"
@@ -23,6 +23,8 @@ BDEPEND="
dev-util/ragel
"
+# We can't default this to on as it's against the expectation of
+# how CPU_FLAGS_* work for users.
REQUIRED_USE="cpu_flags_x86_ssse3"
src_prepare() {