summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2020-06-09 14:25:08 +0200
committerPatrice Clement <monsieurp@gentoo.org>2020-06-09 14:26:21 +0200
commit8f4c72863a37a9f29a8dbf9fae5c27fe8b8b3b43 (patch)
tree64c3949659ba2d69afabe8660a0fe9210d221eb0
parentsys-auth/passwdqc: Version bump (v1.4.0) (diff)
downloadgentoo-8f4c72863a37a9f29a8dbf9fae5c27fe8b8b3b43.tar.gz
gentoo-8f4c72863a37a9f29a8dbf9fae5c27fe8b8b3b43.tar.bz2
gentoo-8f4c72863a37a9f29a8dbf9fae5c27fe8b8b3b43.zip
media-gfx/ttygif: honor CFLAGS and LDFLAGS.
Closes: https://bugs.gentoo.org/727630 Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
-rw-r--r--media-gfx/ttygif/files/ldflags-support.patch19
-rw-r--r--media-gfx/ttygif/ttygif-1.80_p20181218.ebuild12
2 files changed, 29 insertions, 2 deletions
diff --git a/media-gfx/ttygif/files/ldflags-support.patch b/media-gfx/ttygif/files/ldflags-support.patch
new file mode 100644
index 000000000000..201f72fb04a6
--- /dev/null
+++ b/media-gfx/ttygif/files/ldflags-support.patch
@@ -0,0 +1,19 @@
+--- a/Makefile 2020-06-09 12:07:21.881455454 -0000
++++ b/Makefile 2020-06-09 12:08:43.984010587 -0000
+@@ -2,6 +2,7 @@
+ VERSION = '"1.4.0"'
+ CFLAGS += -O2 -Wall -DVERSION=$(VERSION)
+ PREFIX ?= /usr/local
++LDFLAGS ?= -L/usr/lib
+
+ UNAME := $(shell uname)
+ ifeq ($(UNAME), Darwin)
+@@ -14,7 +15,7 @@
+ all: ttygif
+
+ ttygif: ttygif.o io.o string_builder.o utils.o
+- $(CC) $(CFLAGS) -o ttygif ttygif.o io.o string_builder.o utils.o
++ $(CC) $(CFLAGS) -o ttygif ttygif.o io.o string_builder.o utils.o $(LDFLAGS)
+
+ install: ttygif
+ install -d $(PREFIX)/bin
diff --git a/media-gfx/ttygif/ttygif-1.80_p20181218.ebuild b/media-gfx/ttygif/ttygif-1.80_p20181218.ebuild
index 32b4aa70ac51..a88b74156eb8 100644
--- a/media-gfx/ttygif/ttygif-1.80_p20181218.ebuild
+++ b/media-gfx/ttygif/ttygif-1.80_p20181218.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-inherit vcs-snapshot
+inherit vcs-snapshot toolchain-funcs
# Commit Date: Dec 18th 2018
COMMIT="362bc381c1c2449509e732d68f07656caf46b420"
@@ -18,11 +18,19 @@ SLOT="0"
DOCS=( LICENSE README.md )
+PATCHES=( "${FILESDIR}/ldflags-support.patch" )
+
RDEPEND="
x11-apps/xwd
app-misc/ttyrec
media-gfx/imagemagick"
+src_compile() {
+ emake CC=$(tc-getCC) \
+ CFLAGS="${CFLAGS} -DVERSION='\"${PV}\"' -DOS_LINUX" \
+ LDFLAGS="${LDFLAGS}"
+}
+
src_install() {
dobin "${PN}"
einstalldocs