summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 21:04:08 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:55:26 +0100
commit9026f06b89856744a45804c9beafb248d9e5bf3c (patch)
tree5220aebc502f5eaf936ff84f2aa42d35c4da13ec
parentdev-libs/metee: add 3.1.2 (diff)
downloadgentoo-9026f06b89856744a45804c9beafb248d9e5bf3c.tar.gz
gentoo-9026f06b89856744a45804c9beafb248d9e5bf3c.tar.bz2
gentoo-9026f06b89856744a45804c9beafb248d9e5bf3c.zip
dev-libs/nmeap: update EAPI 7 -> 8
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
-rw-r--r--dev-libs/nmeap/nmeap-0.3-r2.ebuild60
1 files changed, 60 insertions, 0 deletions
diff --git a/dev-libs/nmeap/nmeap-0.3-r2.ebuild b/dev-libs/nmeap/nmeap-0.3-r2.ebuild
new file mode 100644
index 000000000000..7a9a57bd5f27
--- /dev/null
+++ b/dev-libs/nmeap/nmeap-0.3-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Extensible NMEA-0183 (GPS) data parser in standard C"
+HOMEPAGE="http://nmeap.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE="doc"
+
+BDEPEND="doc? ( app-doc/doxygen )"
+
+PATCHES=( "${FILESDIR}/${P}-fix-unitialized-variable.patch" )
+
+src_prepare() {
+ default
+
+ # Repsect users CFLAGS for the static lib archive
+ sed -i -e 's/CFLAGS =/CFLAGS +=/' -e 's/-g -O0 -Werror//' src/Makefile || die
+
+ # Don't build test programs, as they are not needed
+ sed -i -e '/TST/d' Makefile || die
+
+ # Silent output of Doxygen and update it, since it is quite old
+ if use doc; then
+ sed -i -e 's/QUIET.*/QUIET = YES/' Doxyfile || die
+ doxygen -u Doxyfile 2>/dev/null || die
+ fi
+}
+
+src_compile() {
+ local myemakeopts=(
+ AR="$(tc-getAR)"
+ CC="$(tc-getCC)"
+ )
+
+ emake "${myemakeopts[@]}"
+
+ if use doc; then
+ doxygen Doxyfile || die
+ fi
+}
+
+src_install() {
+ dolib.a lib/libnmeap.a
+
+ doheader inc/nmeap.h inc/nmeap_def.h
+
+ if use doc; then
+ local HTML_DOCS=( "doc/tutorial.html" "doc/html" )
+ fi
+
+ einstalldocs
+}