summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-08-09 20:54:35 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-08-09 20:58:26 +0300
commit907374ef5d6ee574f4be4f6918a3fdcffa99c4ad (patch)
tree7df28b9ae9b156de430e6acb37bb4dc1ce2658a5
parentdev-python/flask: add 2.2.2 (diff)
downloadgentoo-907374ef5d6ee574f4be4f6918a3fdcffa99c4ad.tar.gz
gentoo-907374ef5d6ee574f4be4f6918a3fdcffa99c4ad.tar.bz2
gentoo-907374ef5d6ee574f4be4f6918a3fdcffa99c4ad.zip
dev-python/google-api-python-client: add 2.56.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
-rw-r--r--dev-python/google-api-python-client/Manifest1
-rw-r--r--dev-python/google-api-python-client/google-api-python-client-2.56.0.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/google-api-python-client/Manifest b/dev-python/google-api-python-client/Manifest
index 60be64d2bd85..34d9ae2b4df0 100644
--- a/dev-python/google-api-python-client/Manifest
+++ b/dev-python/google-api-python-client/Manifest
@@ -1,3 +1,4 @@
DIST google-api-python-client-2.53.0.gh.tar.gz 32251370 BLAKE2B 880024a220bb793b53042c8b2192dee666b7f5ad6dd8b0b68d51ff7b18ebd2ba220974f86656ac13b4c421c191ec66b269007a3f68a1992b0672623db046ef6b SHA512 1cb251d8abbec0b33b62b661ea8235224e94f807571b47e8422b6908b6636f844c639328cf0c07b4820a083b265e71f54dc3f6c48447f0cfd20bca738d7ab86a
DIST google-api-python-client-2.54.0.gh.tar.gz 32389268 BLAKE2B 568ff657ea5093ff927208cd38d0125bf4aea8b725c5ded0a232c4de77f59c97f639b7f2b0ab8cf0e121bafd4512c23f9ac4c3c6cce6b6ab407c6ad2bb5a4983 SHA512 f33525bee9b6cede8955af4e208b64d1c82185cff08173d9ae30a704c3239b9a2ee9972e083fd4a823091b76669a7df02bf60cd950a3e20ddf21c6fd2e5ee18b
DIST google-api-python-client-2.55.0.gh.tar.gz 32614590 BLAKE2B f7344903e4782940cb277b0b4ebc48b36c5b3403ea7f309205c4b27bee3488ecc5cd83b0487989da56b840dda7b0661f598c21307ba9afc9b52137f3b155737d SHA512 c674c038e911140e3ad64426be629d1498db382d96d18a5a51a4c2d5cb4375ad84e21e5dd68aedfa29b4bdc017d7996351f42ff34bff293a4d2c8cfb26820f0d
+DIST google-api-python-client-2.56.0.gh.tar.gz 33165501 BLAKE2B 5b4d72404f15c211cb01ca5291a74c83e9551b28c2e9e268462d481a3b05f557998fba8ed14c1233a023f60813be5b702f88371d47499a18cef152a52577f2ce SHA512 3ea968d11eda34d7807469c1651e8685ae695faed2772acbb23964468fa0cf9036fe468f427cd3f5bccd7c69746729858838446cbd320f0db7edff4add554d81
diff --git a/dev-python/google-api-python-client/google-api-python-client-2.56.0.ebuild b/dev-python/google-api-python-client/google-api-python-client-2.56.0.ebuild
new file mode 100644
index 000000000000..7e8aaa05d6d4
--- /dev/null
+++ b/dev-python/google-api-python-client/google-api-python-client-2.56.0.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Google API Client for Python"
+HOMEPAGE="
+ https://github.com/googleapis/google-api-python-client/
+ https://pypi.org/project/google-api-python-client/
+"
+SRC_URI="
+ https://github.com/googleapis/google-api-python-client/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/httplib2-0.15[${PYTHON_USEDEP}]
+ <dev-python/httplib2-1[${PYTHON_USEDEP}]
+ >=dev-python/google-api-core-2.3.1[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-1.35.0[${PYTHON_USEDEP}]
+ >=dev-python/google-auth-httplib2-0.1.0[${PYTHON_USEDEP}]
+ >=dev-python/uritemplate-3.0.0[${PYTHON_USEDEP}]
+ <dev-python/uritemplate-5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/oauth2client[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # require Internet access (and credentials)
+ tests/test_discovery.py::DiscoveryErrors::test_credentials_and_credentials_file_mutually_exclusive
+ tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_mapping_object
+ )
+
+ epytest tests
+}