summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-15 22:41:32 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-15 23:17:30 +0100
commit90a4e2488f4283e823a171ddea9f733d9bedaeee (patch)
tree77b988d58ba336fc40def38fa78a18f60eb1755b
parentdev-python/xmlschema: Bump to 1.10.0 (diff)
downloadgentoo-90a4e2488f4283e823a171ddea9f733d9bedaeee.tar.gz
gentoo-90a4e2488f4283e823a171ddea9f733d9bedaeee.tar.bz2
gentoo-90a4e2488f4283e823a171ddea9f733d9bedaeee.zip
dev-python/pycairo: Bump to 1.21.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
-rw-r--r--dev-python/pycairo/Manifest1
-rw-r--r--dev-python/pycairo/pycairo-1.21.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/pycairo/Manifest b/dev-python/pycairo/Manifest
index b1b1e0e023c3..1875f1cb5dec 100644
--- a/dev-python/pycairo/Manifest
+++ b/dev-python/pycairo/Manifest
@@ -1 +1,2 @@
DIST pycairo-1.20.1.tar.gz 344639 BLAKE2B 7327a1b9aacc62eb7b2630ac2b9ce43ad7a44e60cb749b60a2973fb9036a84c1f3f4264da428d720158a5e32cd47f679d5956ebf3ce094e75d742584a68adda4 SHA512 bb2340170c1d39d50dd8ceeb1b6ceadd96ddbd27d78a8a5b7dadf7dc427558d766f65d62e1ceeae19ab200e7ffb5ad122b5e51daa8ef9bff08fcd97a44005697
+DIST pycairo-1.21.0.tar.gz 340712 BLAKE2B 6578c75b478c14c641b5c0be44c3c633d32ecc09c4ef22a079024dd12b539d37f88efa6ce8aadb5a88a48b3cc793e573afe00eaa4e3ba563c3133cad72dacfe4 SHA512 0de226b05d0a358f3546e4a0d5bf342f124373718d4900c891a09c1ede11e3ed1fb9bee163c00acfc215044683ddf0b29c8573b7454f9c39f957a47d63c34baf
diff --git a/dev-python/pycairo/pycairo-1.21.0.ebuild b/dev-python/pycairo/pycairo-1.21.0.ebuild
new file mode 100644
index 000000000000..e6e472a24f9f
--- /dev/null
+++ b/dev-python/pycairo/pycairo-1.21.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the cairo library"
+HOMEPAGE="https://www.cairographics.org/pycairo/ https://github.com/pygobject/pycairo"
+SRC_URI="https://github.com/pygobject/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="examples"
+
+BDEPEND="
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="
+ >=x11-libs/cairo-1.15.10[svg]
+"
+DEPEND="${RDEPEND}"
+
+distutils_enable_sphinx docs \
+ dev-python/sphinx_rtd_theme
+distutils_enable_tests setup.py
+
+python_install() {
+ distutils-r1_python_install \
+ install_pkgconfig --pkgconfigdir="${EPREFIX}/usr/$(get_libdir)/pkgconfig"
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ fi
+
+ distutils-r1_python_install_all
+}